summaryrefslogtreecommitdiffstats
path: root/tools/automake
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2008-10-08 21:50:03 +0000
committerLars-Peter Clausen <lars@metafoo.de>2008-10-08 21:50:03 +0000
commit1f819de60e94eab20a63012711e17116a2a9b2a0 (patch)
treeb1b53ef901facf1932ec5b6d1fb6b169275d97d8 /tools/automake
parent1962736dc2b8c59f387ae6509f11807a4427c1d0 (diff)
downloadopenwrt-1f819de60e94eab20a63012711e17116a2a9b2a0.tar.gz
openwrt-1f819de60e94eab20a63012711e17116a2a9b2a0.tar.bz2
openwrt-1f819de60e94eab20a63012711e17116a2a9b2a0.zip
Add wrapper around aclocal which also search in the targets staging dir aclocal folder for m4 files.
SVN-Revision: 12929
Diffstat (limited to 'tools/automake')
-rw-r--r--tools/automake/Makefile5
-rwxr-xr-xtools/automake/files/aclocal5
2 files changed, 9 insertions, 1 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index cf39cbda8b..2b8a6f3450 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -27,6 +27,9 @@ endef
define Build/Install
$(MAKE) -C $(PKG_BUILD_DIR) install
+ mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
+ $(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
+ ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
endef
define Build/Clean
diff --git a/tools/automake/files/aclocal b/tools/automake/files/aclocal
new file mode 100755
index 0000000000..a586ccc61f
--- /dev/null
+++ b/tools/automake/files/aclocal
@@ -0,0 +1,5 @@
+#!/usr/bin/env sh
+aclocal.real \
+ -I ${STAGING_DIR}/host/share/aclocal \
+ -I ${STAGING_DIR}/usr/share/aclocal \
+ $@