summaryrefslogtreecommitdiffstats
path: root/tools/automake
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-28 01:23:56 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-20 00:33:22 +0200
commita63805b25f99e609d575ee920baae269fb58794c (patch)
tree3d7090484571e2b300efdd658033378c250a485e /tools/automake
parentf2ae4e2f8cf698f6fc6ae802dae86f50916f4286 (diff)
downloadopenwrt-a63805b25f99e609d575ee920baae269fb58794c.tar.gz
openwrt-a63805b25f99e609d575ee920baae269fb58794c.tar.bz2
openwrt-a63805b25f99e609d575ee920baae269fb58794c.zip
tools: add Host/Uninstall where possible
This cleans staging_dir when calling tool/x/clean. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/automake')
-rw-r--r--tools/automake/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index c016f1d76a..a1121f1378 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -43,9 +43,8 @@ define Host/Install
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.15
endef
-define Host/Clean
- -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
- $(call Host/Clean/Default)
+define Host/Uninstall
+ -$(call Host/Compile/Default,uninstall)
endef
$(eval $(call HostBuild))