summaryrefslogtreecommitdiffstats
path: root/tools/automake
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-09 14:51:23 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-09 14:51:23 +0000
commitcdaf75b641e6f55ed8de286d1db81d0338add315 (patch)
treec555970f33f6a52a4e25df595f8d7cb75c9dd8c8 /tools/automake
parentda9782f93591fc4856d9fed753a9ee0e3168ede8 (diff)
downloadopenwrt-cdaf75b641e6f55ed8de286d1db81d0338add315.tar.gz
openwrt-cdaf75b641e6f55ed8de286d1db81d0338add315.tar.bz2
openwrt-cdaf75b641e6f55ed8de286d1db81d0338add315.zip
tools: automake: update to v1.15
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 43895
Diffstat (limited to 'tools/automake')
-rw-r--r--tools/automake/Makefile10
-rw-r--r--tools/automake/patches/000-relocatable.patch56
-rw-r--r--tools/automake/patches/100-aclocal-skip-not-existing-directories.patch16
3 files changed, 42 insertions, 40 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index 546f9b2661..300bee21ea 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=automake
-PKG_VERSION:=1.11.6
+PKG_VERSION:=1.15
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/automake
-PKG_MD5SUM:=cf4752287ad708f83bd3689da57a32c9
+PKG_MD5SUM:=9a1ddb0e053474d9d1105cfe39b0c48d
include $(INCLUDE_DIR)/host-build.mk
@@ -19,6 +19,9 @@ HOST_CONFIGURE_ARGS += --datarootdir=$(STAGING_DIR_HOST)/share
HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
define Host/Install
+ # remove old automake resources to avoid version conflicts
+ rm -rf $(STAGING_DIR_HOST)/share/aclocal-[0-9]*
+ rm -rf $(STAGING_DIR_HOST)/share/automake-[0-9]*
$(MAKE) -C $(HOST_BUILD_DIR) install
mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
$(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
@@ -26,6 +29,7 @@ define Host/Install
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.6
+ ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.15
endef
define Host/Clean
diff --git a/tools/automake/patches/000-relocatable.patch b/tools/automake/patches/000-relocatable.patch
index 1206fdc1cb..8e9ee37db4 100644
--- a/tools/automake/patches/000-relocatable.patch
+++ b/tools/automake/patches/000-relocatable.patch
@@ -1,17 +1,27 @@
---- a/aclocal.in
-+++ b/aclocal.in
-@@ -27,7 +27,8 @@
+--- a/lib/Automake/Config.in
++++ b/lib/Automake/Config.in
+@@ -32,7 +32,7 @@ our $PACKAGE = '@PACKAGE@';
+ our $PACKAGE_BUGREPORT = '@PACKAGE_BUGREPORT@';
+ our $VERSION = '@VERSION@';
+ our $RELEASE_YEAR = '@RELEASE_YEAR@';
+-our $libdir = '@datadir@/@PACKAGE@-@APIVERSION@';
++our $libdir = $ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@';
+
+ our $perl_threads = 0;
+ # We need at least this version for CLONE support.
+--- a/bin/aclocal.in
++++ b/bin/aclocal.in
+@@ -27,7 +27,7 @@ eval 'case $# in 0) exec @PERL@ -S "$0";
BEGIN
{
-- my $perllibdir = $ENV{'perllibdir'} || '@datadir@/@PACKAGE@-@APIVERSION@';
-+ my $perllibdir = $ENV{'perllibdir'} ||
-+ ($ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@');
- unshift @INC, (split '@PATH_SEPARATOR@', $perllibdir);
+- @Aclocal::perl_libdirs = ('@datadir@/@PACKAGE@-@APIVERSION@')
++ @Aclocal::perl_libdirs = ($ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@')
+ unless @Aclocal::perl_libdirs;
+ unshift @INC, @Aclocal::perl_libdirs;
}
-
-@@ -58,8 +59,8 @@
- # ACLOCAL_PATH environment variable, and reset with the `--system-acdir'
+@@ -69,8 +69,8 @@ $perl_threads = 0;
+ # ACLOCAL_PATH environment variable, and reset with the '--system-acdir'
# option.
my @user_includes = ();
-my @automake_includes = ("@datadir@/aclocal-$APIVERSION");
@@ -21,26 +31,14 @@
# Whether we should copy M4 file in $user_includes[0].
my $install = 0;
---- a/automake.in
-+++ b/automake.in
-@@ -31,7 +31,8 @@
+--- a/bin/automake.in
++++ b/bin/automake.in
+@@ -31,7 +31,7 @@ use strict;
BEGIN
{
-- my $perllibdir = $ENV{'perllibdir'} || '@datadir@/@PACKAGE@-@APIVERSION@';
-+ my $perllibdir = $ENV{'perllibdir'} ||
-+ ($ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@');
- unshift @INC, (split '@PATH_SEPARATOR@', $perllibdir);
-
- # Override SHELL. This is required on DJGPP so that system() uses
---- a/lib/Automake/Config.in
-+++ b/lib/Automake/Config.in
-@@ -31,7 +31,7 @@
- our $PACKAGE = '@PACKAGE@';
- our $PACKAGE_BUGREPORT = '@PACKAGE_BUGREPORT@';
- our $VERSION = '@VERSION@';
--our $libdir = '@datadir@/@PACKAGE@-@APIVERSION@';
-+our $libdir = $ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@';
- our $perl_threads = @PERL_THREADS@;
+- @Automake::perl_libdirs = ('@datadir@/@PACKAGE@-@APIVERSION@')
++ @Automake::perl_libdirs = ($ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@')
+ unless @Automake::perl_libdirs;
+ unshift @INC, @Automake::perl_libdirs;
- 1;
diff --git a/tools/automake/patches/100-aclocal-skip-not-existing-directories.patch b/tools/automake/patches/100-aclocal-skip-not-existing-directories.patch
index e6c3d7f335..caaad084a4 100644
--- a/tools/automake/patches/100-aclocal-skip-not-existing-directories.patch
+++ b/tools/automake/patches/100-aclocal-skip-not-existing-directories.patch
@@ -1,15 +1,15 @@
---- a/aclocal.in
-+++ b/aclocal.in
-@@ -327,6 +327,12 @@
+--- a/bin/aclocal.in
++++ b/bin/aclocal.in
+@@ -354,6 +354,12 @@ sub scan_m4_dirs ($$@)
foreach my $m4dir (@dirlist)
{
+ if (! -d $m4dir)
-+ {
-+ msg ('override', "warning: skipping not existing directory `$m4dir'");
-+ next;
-+ }
++ {
++ msg ('override', "warning: skipping not existing directory `$m4dir'");
++ next;
++ }
+
if (! opendir (DIR, $m4dir))
{
- if ($install && $type == FT_USER && $first_user_m4dir)
+ # TODO: maybe avoid complaining only if errno == ENONENT?