summaryrefslogtreecommitdiffstats
path: root/tools/automake
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-08-01 08:30:43 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2023-03-13 22:53:41 +0100
commitf509935fe3bf85dcd5cce98beb32d426b3ea11f2 (patch)
tree3dec348fc3410049c06cda4faab45bb0212bc691 /tools/automake
parent030447b8f4c70cf8313dd8de5a3f70e2ad1de375 (diff)
downloadopenwrt-f509935fe3bf85dcd5cce98beb32d426b3ea11f2.tar.gz
openwrt-f509935fe3bf85dcd5cce98beb32d426b3ea11f2.tar.bz2
openwrt-f509935fe3bf85dcd5cce98beb32d426b3ea11f2.zip
tools/automake: bump to 1.16.5
Automake releases 1.16.2 to 1.16.5 are major releases, the two before are minor releases. The first patch needed rewriting, some lines moved to be consistent with the same change upstream in other files. This also simplifies the patch. Second patch refreshed. Links to changelogs in order, oldest to newest. Link: https://lists.gnu.org/archive/html/info-gnu/2018-02/msg00008.html Link: https://lists.gnu.org/archive/html/info-gnu/2018-03/msg00002.html Link: https://lists.gnu.org/archive/html/info-gnu/2020-03/msg00009.html Link: https://lists.gnu.org/archive/html/info-gnu/2020-11/msg00005.html Link: https://lists.gnu.org/archive/html/info-gnu/2021-07/msg00013.html Link: https://lists.gnu.org/archive/html/info-gnu/2021-10/msg00000.html Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'tools/automake')
-rw-r--r--tools/automake/Makefile4
-rw-r--r--tools/automake/patches/000-relocatable.patch80
-rw-r--r--tools/automake/patches/100-aclocal-skip-not-existing-directories.patch2
3 files changed, 21 insertions, 65 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index 246e1814b7..4c1e5758cb 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -8,12 +8,12 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=automake
PKG_CPE_ID:=cpe:/a:gnu:automake
-PKG_VERSION:=1.15.1
+PKG_VERSION:=1.16.5
PKG_API_VERSION:=$(word 2,$(subst ., ,$(PKG_VERSION)))
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/automake
-PKG_HASH:=af6ba39142220687c500f79b4aa2f181d9b24e4f8d8ec497cea4ba26c64bedaf
+PKG_HASH:=f01d58cd6d9d77fbdca9eb4bbd5ead1988228fdb73d6f7a201f5f8d6b118b469
include $(INCLUDE_DIR)/host-build.mk
diff --git a/tools/automake/patches/000-relocatable.patch b/tools/automake/patches/000-relocatable.patch
index 02382ba8c8..0b61eaeb45 100644
--- a/tools/automake/patches/000-relocatable.patch
+++ b/tools/automake/patches/000-relocatable.patch
@@ -1,44 +1,34 @@
--- a/lib/Automake/Config.in
+++ b/lib/Automake/Config.in
-@@ -32,7 +32,7 @@ our $PACKAGE = '@PACKAGE@';
+@@ -34,7 +34,7 @@ our $PACKAGE = '@PACKAGE@';
our $PACKAGE_BUGREPORT = '@PACKAGE_BUGREPORT@';
our $VERSION = '@VERSION@';
our $RELEASE_YEAR = '@RELEASE_YEAR@';
--our $libdir = '@datadir@/@PACKAGE@-@APIVERSION@';
+-our $libdir = $ENV{"AUTOMAKE_LIBDIR"} || '@datadir@/@PACKAGE@-@APIVERSION@';
+our $libdir = $ENV{'STAGING_DIR_HOST'} ? $ENV{'STAGING_DIR_HOST'} . '/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@';
our $perl_threads = 0;
# We need at least this version for CLONE support.
--- a/bin/aclocal.in
+++ b/bin/aclocal.in
-@@ -1,10 +1,12 @@
--#!@PERL@ -w
-+#!@PERL@
- # -*- perl -*-
- # @configure_input@
-
- eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
- if 0;
+@@ -23,9 +23,11 @@ use 5.006;
+ use strict;
+ use warnings FATAL => 'all';
+$^W = 1;
+
- # aclocal - create aclocal.m4 by scanning configure.ac
-
- # Copyright (C) 1996-2017 Free Software Foundation, Inc.
-@@ -27,7 +29,7 @@ eval 'case $# in 0) exec @PERL@ -S "$0";
-
BEGIN
{
-- @Aclocal::perl_libdirs = ('@datadir@/@PACKAGE@-@APIVERSION@')
-+ @Aclocal::perl_libdirs = ($ENV{'STAGING_DIR_HOST'} ? $ENV{'STAGING_DIR_HOST'} . '/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@')
- unless @Aclocal::perl_libdirs;
- unshift @INC, @Aclocal::perl_libdirs;
+- unshift (@INC, '@datadir@/@PACKAGE@-@APIVERSION@')
++ unshift (@INC, ($ENV{'STAGING_DIR_HOST'} ? $ENV{'STAGING_DIR_HOST'} . '/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@'))
+ unless $ENV{AUTOMAKE_UNINSTALLED};
}
-@@ -69,8 +71,8 @@ $perl_threads = 0;
+
+@@ -65,8 +67,8 @@ $perl_threads = 0;
# ACLOCAL_PATH environment variable, and reset with the '--system-acdir'
# option.
my @user_includes = ();
--my @automake_includes = ("@datadir@/aclocal-$APIVERSION");
+-my @automake_includes = ('@datadir@/aclocal-' . $APIVERSION);
-my @system_includes = ('@datadir@/aclocal');
+my @automake_includes = ($ENV{'STAGING_DIR_HOST'} ? $ENV{'STAGING_DIR_HOST'} . "/share/aclocal-$APIVERSION" : "@datadir@/aclocal-$APIVERSION");
+my @system_includes = ($ENV{'STAGING_DIR_HOST'} ? $ENV{'STAGING_DIR_HOST'} . '/share/aclocal' : '@datadir@/aclocal');
@@ -47,50 +37,16 @@
my $install = 0;
--- a/bin/automake.in
+++ b/bin/automake.in
-@@ -1,10 +1,12 @@
--#!@PERL@ -w
-+#!@PERL@
- # -*- perl -*-
- # @configure_input@
-
- eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
- if 0;
+@@ -26,9 +26,11 @@ use 5.006;
+ use strict;
+ use warnings FATAL => 'all';
+$^W = 1;
+
- # automake - create Makefile.in from Makefile.am
- # Copyright (C) 1994-2017 Free Software Foundation, Inc.
-
-@@ -31,7 +33,7 @@ use strict;
-
BEGIN
{
-- @Automake::perl_libdirs = ('@datadir@/@PACKAGE@-@APIVERSION@')
-+ @Automake::perl_libdirs = ($ENV{'STAGING_DIR_HOST'} ? $ENV{'STAGING_DIR_HOST'} . '/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@')
- unless @Automake::perl_libdirs;
- unshift @INC, @Automake::perl_libdirs;
-
---- a/t/wrap/aclocal.in
-+++ b/t/wrap/aclocal.in
-@@ -1,6 +1,8 @@
--#!@PERL@ -w
-+#!@PERL@
- # @configure_input@
-
-+$^W = 1;
-+
- # Copyright (C) 2012-2017 Free Software Foundation, Inc.
-
- # This program is free software; you can redistribute it and/or modify
---- a/t/wrap/automake.in
-+++ b/t/wrap/automake.in
-@@ -1,6 +1,8 @@
--#!@PERL@ -w
-+#!@PERL@
- # @configure_input@
-
-+$^W = 1;
-+
- # Copyright (C) 2012-2017 Free Software Foundation, Inc.
+- unshift (@INC, '@datadir@/@PACKAGE@-@APIVERSION@')
++ unshift (@INC, ($ENV{'STAGING_DIR_HOST'} ? $ENV{'STAGING_DIR_HOST'} . '/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@'))
+ unless $ENV{AUTOMAKE_UNINSTALLED};
- # This program is free software; you can redistribute it and/or modify
+ # Override SHELL. This is required on DJGPP so that system() uses
diff --git a/tools/automake/patches/100-aclocal-skip-not-existing-directories.patch b/tools/automake/patches/100-aclocal-skip-not-existing-directories.patch
index ad019ddd1a..a0d04e21e5 100644
--- a/tools/automake/patches/100-aclocal-skip-not-existing-directories.patch
+++ b/tools/automake/patches/100-aclocal-skip-not-existing-directories.patch
@@ -1,6 +1,6 @@
--- a/bin/aclocal.in
+++ b/bin/aclocal.in
-@@ -356,6 +356,12 @@ sub scan_m4_dirs ($$@)
+@@ -371,6 +371,12 @@ sub scan_m4_dirs ($$@)
foreach my $m4dir (@dirlist)
{