summaryrefslogtreecommitdiffstats
path: root/tools/b43-tools
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2024-03-29 18:57:03 +0100
committerRobert Marko <robimarko@gmail.com>2024-03-30 10:42:47 +0100
commit0c96d20bf9fba6d814efa88c6fb08a5df094103a (patch)
tree127ca8c16095c13cc617b197a9ac9c83b867bdea /tools/b43-tools
parentd7d94a8d91bc1dc9dcedbe004021509871acac24 (diff)
downloadopenwrt-0c96d20bf9fba6d814efa88c6fb08a5df094103a.tar.gz
openwrt-0c96d20bf9fba6d814efa88c6fb08a5df094103a.tar.bz2
openwrt-0c96d20bf9fba6d814efa88c6fb08a5df094103a.zip
tools: b43-tools: fix compilation with GCC14
GCC14 no longer treats integer types and pointer types as equivalent in assignments (including implied assignments of function arguments and return values), and instead fails the compilation with a type error. So, as a workaround lets disable the newly introduced error -Werror=int-conversion and just make it print a warning to enable compiling with GCC14 as Fedora 40 now defaults to it. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'tools/b43-tools')
-rw-r--r--tools/b43-tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/b43-tools/Makefile b/tools/b43-tools/Makefile
index d3f6e80b52..ed8030e9c5 100644
--- a/tools/b43-tools/Makefile
+++ b/tools/b43-tools/Makefile
@@ -23,7 +23,7 @@ define Host/Compile
$(HOST_MAKE_FLAGS) \
$(1) QUIET_SPARSE=:
+$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/assembler \
- CFLAGS="$(HOST_CFLAGS) -include endian.h" \
+ CFLAGS="$(HOST_CFLAGS) -include endian.h -Wno-error=int-conversion" \
$(HOST_MAKE_FLAGS) \
LDFLAGS= \
$(1) QUIET_SPARSE=: