summaryrefslogtreecommitdiffstats
path: root/tools/bison
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2019-02-10 12:16:30 +0000
committerHans Dedecker <dedeckeh@gmail.com>2019-02-10 20:49:56 +0100
commita3383e4b016478c73cf149ae7f42ad8f9b87ffbb (patch)
treeccbed03a1b10eb5178af50d3ba1e103e454b68c5 /tools/bison
parenta3df068b3119585d2c46807a1ff0d66956da954b (diff)
downloadopenwrt-a3383e4b016478c73cf149ae7f42ad8f9b87ffbb.tar.gz
openwrt-a3383e4b016478c73cf149ae7f42ad8f9b87ffbb.tar.bz2
openwrt-a3383e4b016478c73cf149ae7f42ad8f9b87ffbb.zip
tools/bison: Update to 3.3.2
Update bison to 3.3.2 Enable pthreads support Refresh patches Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'tools/bison')
-rw-r--r--tools/bison/Makefile6
-rw-r--r--tools/bison/patches/010-intl-stub-compat.patch22
2 files changed, 14 insertions, 14 deletions
diff --git a/tools/bison/Makefile b/tools/bison/Makefile
index 139dbc763b..2dcbe617af 100644
--- a/tools/bison/Makefile
+++ b/tools/bison/Makefile
@@ -7,16 +7,18 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bison
-PKG_VERSION:=3.2.4
+PKG_VERSION:=3.3.2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_HASH:=523d44419f4df68286503740c95c7b3400b748d7d8b797209195ee5d67f05634
+PKG_HASH:=039ee45b61d95e5003e7e8376f9080001b4066ff357bde271b7faace53b9d804
HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+HOST_CONFIGURE_ARGS += --enable-threads=pth
+
define Host/Clean
-$(MAKE) -C $(HOST_BUILD_DIR) uninstall
$(call Host/Clean/Default)
diff --git a/tools/bison/patches/010-intl-stub-compat.patch b/tools/bison/patches/010-intl-stub-compat.patch
index d2dfcadbab..8108c53c61 100644
--- a/tools/bison/patches/010-intl-stub-compat.patch
+++ b/tools/bison/patches/010-intl-stub-compat.patch
@@ -1,15 +1,13 @@
--- a/src/main.c
+++ b/src/main.c
-@@ -60,9 +60,9 @@ main (int argc, char *argv[])
- {
- set_program_name (argv[0]);
- setlocale (LC_ALL, "");
-- (void) bindtextdomain (PACKAGE, LOCALEDIR);
-- (void) bindtextdomain ("bison-runtime", LOCALEDIR);
-- (void) textdomain (PACKAGE);
-+ bindtextdomain (PACKAGE, LOCALEDIR);
-+ bindtextdomain ("bison-runtime", LOCALEDIR);
-+ textdomain (PACKAGE);
-
+@@ -66,8 +66,8 @@ main (int argc, char *argv[])
{
- char const *cp = getenv ("LC_CTYPE");
+ char *cp = NULL;
+ char const *localedir = relocate2 (LOCALEDIR, &cp);
+- (void) bindtextdomain (PACKAGE, localedir);
+- (void) bindtextdomain ("bison-runtime", localedir);
++ bindtextdomain (PACKAGE, localedir);
++ bindtextdomain ("bison-runtime", localedir);
+ free (cp);
+ }
+ (void) textdomain (PACKAGE);