summaryrefslogtreecommitdiffstats
path: root/tools/ccache
diff options
context:
space:
mode:
authorRaihaan Shouhell <raihaanhimself@gmail.com>2022-10-22 21:10:34 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-31 22:00:15 +0100
commit06e34a05f9e96d319d426d9bbbfebea9a62cac07 (patch)
treedd9aaf7006184f0cf560c6e65ab5a7545540837b /tools/ccache
parentda5c45f4d8864a82378b4a04c0516cb98a718cfa (diff)
downloadopenwrt-06e34a05f9e96d319d426d9bbbfebea9a62cac07.tar.gz
openwrt-06e34a05f9e96d319d426d9bbbfebea9a62cac07.tar.bz2
openwrt-06e34a05f9e96d319d426d9bbbfebea9a62cac07.zip
tools/ccache: update to 4.7
Release Notes: https://ccache.dev/releasenotes.html#_ccache_4_7 Signed-off-by: Raihaan Shouhell <raihaanhimself@gmail.com>
Diffstat (limited to 'tools/ccache')
-rw-r--r--tools/ccache/Makefile4
-rw-r--r--tools/ccache/patches/100-honour-copts.patch16
2 files changed, 10 insertions, 10 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index 0cf528bb5f..644aa3b5e8 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=ccache
-PKG_VERSION:=4.6.3
+PKG_VERSION:=4.7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
-PKG_HASH:=1e3a251bb112632553b8255a78661fe526c3a16598496d51128c32b218fd8b22
+PKG_HASH:=d9283bbe22085268f52d309b91adb81a77a7abe10867eb6852057910ffac736a
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/cmake.mk
diff --git a/tools/ccache/patches/100-honour-copts.patch b/tools/ccache/patches/100-honour-copts.patch
index c8f2fc0fe6..6a4834e123 100644
--- a/tools/ccache/patches/100-honour-copts.patch
+++ b/tools/ccache/patches/100-honour-copts.patch
@@ -1,10 +1,10 @@
--- a/src/ccache.cpp
+++ b/src/ccache.cpp
-@@ -1756,6 +1756,7 @@ calculate_result_and_manifest_key(Contex
- "CPLUS_INCLUDE_PATH",
- "OBJC_INCLUDE_PATH",
- "OBJCPLUS_INCLUDE_PATH", // clang
-+ "GCC_HONOUR_COPTS",
- nullptr};
- for (const char** p = envvars; *p; ++p) {
- const char* v = getenv(*p);
+@@ -1743,6 +1743,7 @@ get_manifest_key(Context& ctx, Hash& hash)
+ "CPLUS_INCLUDE_PATH",
+ "OBJC_INCLUDE_PATH",
+ "OBJCPLUS_INCLUDE_PATH", // clang
++ "GCC_HONOUR_COPTS",
+ nullptr};
+ for (const char** p = envvars; *p; ++p) {
+ const char* v = getenv(*p);