summaryrefslogtreecommitdiffstats
path: root/tools/ccache
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>2017-03-03 11:49:06 +0000
committerFelix Fietkau <nbd@nbd.name>2017-03-12 15:06:50 +0100
commit2cf00b640dce3ee9b09b41f2f1486a6a50bca45b (patch)
tree027ba3b76f63030f412d60e0ac3ce6d0f0a8729b /tools/ccache
parent08371a2db76ecba5236ae8aec1d57fee84e312d8 (diff)
downloadopenwrt-2cf00b640dce3ee9b09b41f2f1486a6a50bca45b.tar.gz
openwrt-2cf00b640dce3ee9b09b41f2f1486a6a50bca45b.tar.bz2
openwrt-2cf00b640dce3ee9b09b41f2f1486a6a50bca45b.zip
ccache: update to 3.3.4
Update from 3.3.2 to 3.3.4 & refresh patches. Remove 110-disable-assembler-support as ccache now understands the '.incbin' directive. Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
Diffstat (limited to 'tools/ccache')
-rw-r--r--tools/ccache/Makefile4
-rw-r--r--tools/ccache/patches/100-honour-copts.patch4
-rw-r--r--tools/ccache/patches/110-disable-assembler-support.patch32
3 files changed, 3 insertions, 37 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index 1ff63e7630..ff8ff6c057 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -8,12 +8,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=ccache
-PKG_VERSION:=3.3.2
+PKG_VERSION:=3.3.4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://download.samba.org/pub/ccache/ \
https://samba.org/ftp/ccache/
-PKG_HASH:=907685cb23d8f82074b8d1a9b4ebabb36914d151ac7b96a840c68c08d1a14530
+PKG_HASH:=24f15bf389e38c41548c9c259532187774ec0cb9686c3497bbb75504c8dc404f
include $(INCLUDE_DIR)/host-build.mk
diff --git a/tools/ccache/patches/100-honour-copts.patch b/tools/ccache/patches/100-honour-copts.patch
index fc82aa4614..141479519f 100644
--- a/tools/ccache/patches/100-honour-copts.patch
+++ b/tools/ccache/patches/100-honour-copts.patch
@@ -1,8 +1,6 @@
-diff --git a/ccache.c b/ccache.c
-index 88e0ec5..7dffeb4 100644
--- a/ccache.c
+++ b/ccache.c
-@@ -1762,6 +1762,7 @@ calculate_object_hash(struct args *args, struct mdfour *hash, int direct_mode)
+@@ -1790,6 +1790,7 @@ calculate_object_hash(struct args *args,
"CPLUS_INCLUDE_PATH",
"OBJC_INCLUDE_PATH",
"OBJCPLUS_INCLUDE_PATH", // clang
diff --git a/tools/ccache/patches/110-disable-assembler-support.patch b/tools/ccache/patches/110-disable-assembler-support.patch
deleted file mode 100644
index 3e6cd8cac7..0000000000
--- a/tools/ccache/patches/110-disable-assembler-support.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- a/language.c
-+++ b/language.c
-@@ -37,14 +37,18 @@ static const struct {
- {".m", "objective-c"},
- {".M", "objective-c++"},
- {".mm", "objective-c++"},
-+#if 0
- {".sx", "assembler-with-cpp"},
- {".S", "assembler-with-cpp"},
-+#endif
- // Preprocessed:
- {".i", "cpp-output"},
- {".ii", "c++-cpp-output"},
- {".mi", "objective-c-cpp-output"},
- {".mii", "objective-c++-cpp-output"},
-+#if 0
- {".s", "assembler"},
-+#endif
- // Header file (for precompilation):
- {".h", "c-header"},
- {".H", "c++-header"},
-@@ -109,8 +113,10 @@ static const struct {
- {"objective-c++-header", "objective-c++-cpp-output"},
- {"objective-c++-cpp-output", "objective-c++-cpp-output"},
- {"cuda", "cuda-output"},
-+#if 0
- {"assembler-with-cpp", "assembler"},
- {"assembler", "assembler"},
-+#endif
- {"f77-cpp-input", "f77"},
- {"f77", "f77"},
- #if 0 // Could generate module files, ignore for now!