summaryrefslogtreecommitdiffstats
path: root/tools/ccache
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2024-02-02 13:34:24 +0100
committerNick Hainke <vincent@systemli.org>2024-02-02 17:32:50 +0100
commit359593193479434a79c7fbab5d23dad7d633e91d (patch)
tree5690567b70e68c5fe8e64a8f4c0925c800e3ca60 /tools/ccache
parentdd53aeaaa26d9c4d7b39929adce0833375eecc7f (diff)
downloadopenwrt-359593193479434a79c7fbab5d23dad7d633e91d.tar.gz
openwrt-359593193479434a79c7fbab5d23dad7d633e91d.tar.bz2
openwrt-359593193479434a79c7fbab5d23dad7d633e91d.zip
tools/ccache: update to 4.9
Release Notes: https://ccache.dev/releasenotes.html#_ccache_4_9 Manually refresh patch: - 100-honour-copts.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'tools/ccache')
-rw-r--r--tools/ccache/Makefile4
-rw-r--r--tools/ccache/patches/100-honour-copts.patch14
2 files changed, 9 insertions, 9 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index f76be9f90e..ace6bc3f42 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ccache
-PKG_VERSION:=4.8.3
+PKG_VERSION:=4.9
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
-PKG_HASH:=e47374c810b248cfca3665ee1d86c7c763ffd68d9944bc422d9c1872611f2b11
+PKG_HASH:=1ebc72324e3ab52af0b562bf54189d108e85eef6478d6304a345a3c2dc4018e0
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/cmake.mk
diff --git a/tools/ccache/patches/100-honour-copts.patch b/tools/ccache/patches/100-honour-copts.patch
index 91dc35536f..becfc9fe29 100644
--- a/tools/ccache/patches/100-honour-copts.patch
+++ b/tools/ccache/patches/100-honour-copts.patch
@@ -1,10 +1,10 @@
--- a/src/ccache.cpp
+++ b/src/ccache.cpp
-@@ -1815,6 +1815,7 @@ get_manifest_key(Context& ctx, Hash& has
- "CPLUS_INCLUDE_PATH",
- "OBJC_INCLUDE_PATH",
- "OBJCPLUS_INCLUDE_PATH", // clang
-+ "GCC_HONOUR_COPTS",
- nullptr};
+@@ -1843,6 +1843,7 @@ get_manifest_key(Context& ctx, Hash& has
+ "OBJCPLUS_INCLUDE_PATH", // Clang
+ "CLANG_CONFIG_FILE_SYSTEM_DIR", // Clang
+ "CLANG_CONFIG_FILE_USER_DIR", // Clang
++ "GCC_HONOUR_COPTS",
+ nullptr,
+ };
for (const char** p = envvars; *p; ++p) {
- const char* v = getenv(*p);