summaryrefslogtreecommitdiffstats
path: root/tools/ccache
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-10-04 18:37:34 -0700
committerPaul Spooren <mail@aparcar.org>2021-10-10 13:05:54 -1000
commit977bf5e9802bf4543e6356e391851b13ee32a1f9 (patch)
treef58ce24bab1ec8acb349b560c5f1533a2fa925d3 /tools/ccache
parent80b7a8a7f5a0a88fde6dd19f097df4d7cac9ff04 (diff)
downloadopenwrt-977bf5e9802bf4543e6356e391851b13ee32a1f9.tar.gz
openwrt-977bf5e9802bf4543e6356e391851b13ee32a1f9.tar.bz2
openwrt-977bf5e9802bf4543e6356e391851b13ee32a1f9.zip
tools/ccache: update to 4.4.2
Refreshed patch. Disable hiredis backend since it seems to default to it now. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/ccache')
-rw-r--r--tools/ccache/Makefile5
-rw-r--r--tools/ccache/patches/100-honour-copts.patch2
2 files changed, 4 insertions, 3 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index 7c85d549e9..081cc46dd0 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=ccache
-PKG_VERSION:=4.3
+PKG_VERSION:=4.4.2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
-PKG_HASH:=504a0f2184465c306826f035b4bc00bae7500308d6af4abbfb50e33a694989b4
+PKG_HASH:=9200cafbaa5fd62c2600fccb40a18214e57747825e6cdcd76688b4b61c2dcba0
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -22,6 +22,7 @@ CMAKE_HOST_OPTIONS += \
-DCMAKE_CXX_COMPILER_LAUNCHER="" \
-DCMAKE_SKIP_RPATH=FALSE \
-DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOST}/lib" \
+ -DREDIS_STORAGE_BACKEND=OFF
ifneq (docs-$(CONFIG_BUILD_DOCUMENTATION),docs-y)
CMAKE_HOST_OPTIONS += -DENABLE_DOCUMENTATION=OFF
diff --git a/tools/ccache/patches/100-honour-copts.patch b/tools/ccache/patches/100-honour-copts.patch
index 0dcc6598f5..55422985b7 100644
--- a/tools/ccache/patches/100-honour-copts.patch
+++ b/tools/ccache/patches/100-honour-copts.patch
@@ -1,6 +1,6 @@
--- a/src/ccache.cpp
+++ b/src/ccache.cpp
-@@ -1756,6 +1756,7 @@ calculate_result_name(Context& ctx,
+@@ -1633,6 +1633,7 @@ calculate_result_and_manifest_key(Contex
"CPLUS_INCLUDE_PATH",
"OBJC_INCLUDE_PATH",
"OBJCPLUS_INCLUDE_PATH", // clang