summaryrefslogtreecommitdiffstats
path: root/tools/cmake/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-24 16:57:40 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2022-09-29 19:33:17 +0200
commit3848cf458ef998fc9971edd6a01cc9cdb43fbef9 (patch)
treef0fa3d5fa71d9e98fb0bf0c920cfdba502815507 /tools/cmake/Makefile
parent89df3589e6237e5ad9b5cdd9f87c82987b200e37 (diff)
downloadopenwrt-3848cf458ef998fc9971edd6a01cc9cdb43fbef9.tar.gz
openwrt-3848cf458ef998fc9971edd6a01cc9cdb43fbef9.tar.bz2
openwrt-3848cf458ef998fc9971edd6a01cc9cdb43fbef9.zip
tools/cmake: Build without some included libs
Saves a little bit of time when compiling cmake. Added patches to fix searching liblzma and zlib. The issue is that because pkgconfig is not used, the system libraries get used. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/cmake/Makefile')
-rw-r--r--tools/cmake/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index a0695c7d62..2d20113a39 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -32,8 +32,14 @@ HOST_CONFIGURE_VARS += \
HOST_CONFIGURE_ARGS := \
$(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)") \
--prefix="$(STAGING_DIR_HOST)" \
+ --system-expat \
+ --system-liblzma \
+ --system-zlib \
+ --system-zstd \
--generator=Ninja
+HOST_LDFLAGS += -Wl,-rpath,$(STAGING_DIR_HOST)/lib
+
define Host/Compile/Default
+$(NINJA) -C $(HOST_BUILD_DIR) $(1)
endef