summaryrefslogtreecommitdiffstats
path: root/tools/cmake/patches
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-08-21 23:04:58 +0200
committerDaniel Golle <daniel@makrotopia.org>2022-09-07 04:22:39 +0100
commite12504a4d0180dd4c6d148c92e49b452a8c245b1 (patch)
treefc816399797097e12298154829a8033a9d157bd1 /tools/cmake/patches
parent017aea00164edca28b87910ef725a18262bac1b2 (diff)
downloadopenwrt-e12504a4d0180dd4c6d148c92e49b452a8c245b1.tar.gz
openwrt-e12504a4d0180dd4c6d148c92e49b452a8c245b1.tar.bz2
openwrt-e12504a4d0180dd4c6d148c92e49b452a8c245b1.zip
tools/cmake: refresh patches
Previous commit forgot to refresh the patches. This commit refreshes the patches: - 120-curl-fix-libressl-linking.patch - 130-bootstrap_parallel_make_flag.patch Fixes: 3b2f19271cc2 ("tools/cmake: update to 3.24.1") Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'tools/cmake/patches')
-rw-r--r--tools/cmake/patches/120-curl-fix-libressl-linking.patch2
-rw-r--r--tools/cmake/patches/130-bootstrap_parallel_make_flag.patch2
2 files changed, 2 insertions, 2 deletions
diff --git a/tools/cmake/patches/120-curl-fix-libressl-linking.patch b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
index fd05d106c8..6ef37c22cb 100644
--- a/tools/cmake/patches/120-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
@@ -20,7 +20,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -565,6 +565,14 @@ if(CMAKE_USE_OPENSSL)
+@@ -594,6 +594,14 @@ if(CURL_USE_OPENSSL)
endif()
set(SSL_ENABLED ON)
set(USE_OPENSSL ON)
diff --git a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
index dd66989c98..2b3ba361bd 100644
--- a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
+++ b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
@@ -1,6 +1,6 @@
--- a/bootstrap
+++ b/bootstrap
-@@ -1423,7 +1423,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1441,7 +1441,10 @@ int main(){ printf("1%c", (char)0x0a); r
' > "test.c"
cmake_original_make_flags="${cmake_make_flags}"
if test "x${cmake_parallel_make}" != "x"; then