summaryrefslogtreecommitdiffstats
path: root/tools/cmake/patches
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-09-01 19:32:36 -0700
committerHans Dedecker <dedeckeh@gmail.com>2021-09-05 21:28:43 +0200
commiteef7f9ea37366c93039b386ca8e438b26a199214 (patch)
treee164a49566ad0f31bd1f59b4b83ea335d6ac4541 /tools/cmake/patches
parentf431f2c4b654c04d9765b2aabe57a907b9c7b3ea (diff)
downloadopenwrt-eef7f9ea37366c93039b386ca8e438b26a199214.tar.gz
openwrt-eef7f9ea37366c93039b386ca8e438b26a199214.tar.bz2
openwrt-eef7f9ea37366c93039b386ca8e438b26a199214.zip
tools/cmake: update to 3.21.2
Refreshed patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/cmake/patches')
-rw-r--r--tools/cmake/patches/120-curl-fix-libressl-linking.patch2
-rw-r--r--tools/cmake/patches/130-bootstrap_parallel_make_flag.patch2
2 files changed, 2 insertions, 2 deletions
diff --git a/tools/cmake/patches/120-curl-fix-libressl-linking.patch b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
index 1095a4f8ac..97ef5ceb00 100644
--- a/tools/cmake/patches/120-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
@@ -20,7 +20,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -508,6 +508,14 @@ if(CMAKE_USE_OPENSSL)
+@@ -528,6 +528,14 @@ if(CMAKE_USE_OPENSSL)
endif()
set(SSL_ENABLED ON)
set(USE_OPENSSL ON)
diff --git a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
index 512765c5af..3822cba166 100644
--- a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
+++ b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
@@ -1,6 +1,6 @@
--- a/bootstrap
+++ b/bootstrap
-@@ -1397,7 +1397,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1420,7 +1420,10 @@ int main(){ printf("1%c", (char)0x0a); r
' > "test.c"
cmake_original_make_flags="${cmake_make_flags}"
if test "x${cmake_parallel_make}" != "x"; then