summaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2023-08-01 17:56:00 -0700
committerNick Hainke <vincent@systemli.org>2023-08-02 14:09:24 +0200
commit1874a7cfb0589862614aff74d4fd49d499da641f (patch)
treead39bdbc17362e105f588a3412682dbf8a7d9788 /tools/cmake
parent150e6d28f2659b0614e87cc7822e93f488e11ede (diff)
downloadopenwrt-1874a7cfb0589862614aff74d4fd49d499da641f.tar.gz
openwrt-1874a7cfb0589862614aff74d4fd49d499da641f.tar.bz2
openwrt-1874a7cfb0589862614aff74d4fd49d499da641f.zip
tools/cmake: update to 3.27.1
Fix zstd linking again. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/Makefile4
-rw-r--r--tools/cmake/patches/100-no-testing.patch8
-rw-r--r--tools/cmake/patches/120-curl-fix-libressl-linking.patch2
-rw-r--r--tools/cmake/patches/130-bootstrap_parallel_make_flag.patch2
-rw-r--r--tools/cmake/patches/150-zstd-libarchive.patch19
5 files changed, 14 insertions, 21 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index 0c96b017e3..2a0d06d7a7 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
-PKG_VERSION:=3.26.4
+PKG_VERSION:=3.27.1
PKG_VERSION_MAJOR:=$(word 1,$(subst ., ,$(PKG_VERSION))).$(word 2,$(subst ., ,$(PKG_VERSION)))
PKG_RELEASE:=1
PKG_CPE_ID:=cpe:/a:kitware:cmake
@@ -15,7 +15,7 @@ PKG_CPE_ID:=cpe:/a:kitware:cmake
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/Kitware/CMake/releases/download/v$(PKG_VERSION)/ \
https://cmake.org/files/v$(PKG_VERSION_MAJOR)/
-PKG_HASH:=313b6880c291bd4fe31c0aa51d6e62659282a521e695f30d5cc0d25abbd5c208
+PKG_HASH:=b1a6b0135fa11b94476e90f5b32c4c8fad480bf91cf22d0ded98ce22c5132004
HOST_BUILD_PARALLEL:=1
HOST_CONFIGURE_PARALLEL:=1
diff --git a/tools/cmake/patches/100-no-testing.patch b/tools/cmake/patches/100-no-testing.patch
index 44452ce39e..736a365e87 100644
--- a/tools/cmake/patches/100-no-testing.patch
+++ b/tools/cmake/patches/100-no-testing.patch
@@ -11,15 +11,15 @@
# like vs9 or vs10
--- a/Modules/Dart.cmake
+++ b/Modules/Dart.cmake
-@@ -33,7 +33,7 @@ whether testing support should be enable
- #
- #
+@@ -47,7 +47,7 @@ if(cmp0145 STREQUAL "")
+ message(AUTHOR_WARNING "${_cmp0145_warning}")
+ endif()
-option(BUILD_TESTING "Build the testing tree." ON)
+option(BUILD_TESTING "Build the testing tree." OFF)
if(BUILD_TESTING)
- find_package(Dart QUIET)
+ # We only get here if a project already ran include(Dart),
--- a/Tests/Contracts/VTK/Dashboard.cmake.in
+++ b/Tests/Contracts/VTK/Dashboard.cmake.in
@@ -25,7 +25,7 @@ ctest_empty_binary_directory(${CTEST_BIN
diff --git a/tools/cmake/patches/120-curl-fix-libressl-linking.patch b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
index 1744fe5b04..b899d1d7ef 100644
--- a/tools/cmake/patches/120-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
@@ -20,7 +20,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -611,6 +611,14 @@ if(CURL_USE_OPENSSL)
+@@ -590,6 +590,14 @@ if(CURL_USE_OPENSSL)
endif()
set(SSL_ENABLED ON)
set(USE_OPENSSL ON)
diff --git a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
index 70d122c9d9..983f376254 100644
--- a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
+++ b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
@@ -1,6 +1,6 @@
--- a/bootstrap
+++ b/bootstrap
-@@ -1449,7 +1449,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1486,7 +1486,10 @@ int main(){ printf("1%c", (char)0x0a); r
' > "test.c"
cmake_original_make_flags="${cmake_make_flags}"
if test "x${cmake_parallel_make}" != "x"; then
diff --git a/tools/cmake/patches/150-zstd-libarchive.patch b/tools/cmake/patches/150-zstd-libarchive.patch
index 34f7240fe4..4ed099fbfe 100644
--- a/tools/cmake/patches/150-zstd-libarchive.patch
+++ b/tools/cmake/patches/150-zstd-libarchive.patch
@@ -1,18 +1,11 @@
--- a/Utilities/cmlibarchive/CMakeLists.txt
+++ b/Utilities/cmlibarchive/CMakeLists.txt
-@@ -632,8 +632,13 @@ IF(ENABLE_ZSTD)
+@@ -636,7 +636,7 @@ IF(ENABLE_ZSTD)
SET(ZSTD_FIND_QUIETLY TRUE)
ENDIF (ZSTD_INCLUDE_DIR)
-- FIND_PATH(ZSTD_INCLUDE_DIR zstd.h)
-- FIND_LIBRARY(ZSTD_LIBRARY NAMES zstd libzstd)
-+ IF(UNIX)
-+ FIND_PACKAGE(PkgConfig QUIET)
-+ PKG_SEARCH_MODULE(PC_ZSTD libzstd)
-+ ENDIF()
-+
-+ FIND_PATH(ZSTD_INCLUDE_DIR zstd.h HINTS ${PC_ZSTD_INCLUDEDIR} ${PC_ZSTD_INCLUDE_DIRS})
-+ FIND_LIBRARY(ZSTD_LIBRARY NAMES zstd HINTS ${PC_ZSTD_LIBDIR} ${PC_ZSTD_LIBRARY_DIRS})
- INCLUDE(FindPackageHandleStandardArgs)
- FIND_PACKAGE_HANDLE_STANDARD_ARGS(ZSTD DEFAULT_MSG ZSTD_LIBRARY ZSTD_INCLUDE_DIR)
- ELSE(ENABLE_ZSTD)
+- IF(0) # CMake does not let pkg-config override its search paths.
++ IF(1) # CMake does not let pkg-config override its search paths.
+ IF(UNIX)
+ FIND_PACKAGE(PkgConfig QUIET)
+ PKG_SEARCH_MODULE(PC_ZSTD libzstd)