summaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2024-03-24 10:59:22 +0100
committerFelix Fietkau <nbd@nbd.name>2024-03-29 15:40:25 +0100
commit383b68e73cc9f4cdeaa92b2cf7d20142a4a9a9ae (patch)
tree59596a2357b46ba26ce6b86decad62faea7f8896 /tools/cmake
parentc9ae8fd3d45f5d05a03c40a46573f2e982b5f139 (diff)
downloadopenwrt-383b68e73cc9f4cdeaa92b2cf7d20142a4a9a9ae.tar.gz
openwrt-383b68e73cc9f4cdeaa92b2cf7d20142a4a9a9ae.tar.bz2
openwrt-383b68e73cc9f4cdeaa92b2cf7d20142a4a9a9ae.zip
tools/cmake: disable xcode generator
Fixes build on latest macOS SDK Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/patches/160-disable_xcode_generator.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/tools/cmake/patches/160-disable_xcode_generator.patch b/tools/cmake/patches/160-disable_xcode_generator.patch
new file mode 100644
index 0000000000..20d1086bd4
--- /dev/null
+++ b/tools/cmake/patches/160-disable_xcode_generator.patch
@@ -0,0 +1,22 @@
+--- a/Source/CMakeLists.txt
++++ b/Source/CMakeLists.txt
+@@ -846,7 +846,7 @@ if(CMake_USE_XCOFF_PARSER)
+ endif()
+
+ # Xcode only works on Apple
+-if(APPLE)
++if(APPLE_DISABLED)
+ target_sources(
+ CMakeLib
+ PRIVATE
+--- a/Source/cmake.cxx
++++ b/Source/cmake.cxx
+@@ -132,7 +132,7 @@
+ # include "cmGlobalGhsMultiGenerator.h"
+ #endif
+
+-#if defined(__APPLE__)
++#if defined(__APPLE_DISABLED__)
+ # if !defined(CMAKE_BOOTSTRAP)
+ # include "cmGlobalXCodeGenerator.h"
+