summaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-10-12 18:07:11 -0400
committerNick Hainke <vincent@systemli.org>2023-10-13 09:27:18 +0200
commit518923178cfeba6a05ca6fb610f9c6d6e808fd75 (patch)
tree053ee7045c75a9c111997507d2e7a586af17a6d4 /tools/cmake
parent802a5f5cb4a7b42d25e82b787d7ab1323a20183f (diff)
downloadopenwrt-518923178cfeba6a05ca6fb610f9c6d6e808fd75.tar.gz
openwrt-518923178cfeba6a05ca6fb610f9c6d6e808fd75.tar.bz2
openwrt-518923178cfeba6a05ca6fb610f9c6d6e808fd75.zip
tools/cmake: disable cmake script debugger
Upstream commit a9a592f96e6498da302f8e968be1db0ad3c32123 ("cmake: Add debugger") added a huge amount of code in order to create a debugging feature for CMakeLists.txt of other projects. This was added to CMake since 3.27.x. Unforunately, this new debugger will not build on ARM systems like arm-linux-gnueabihf (Raspberry Pi 4), and takes up extra build time for something Openwrt doesn't need, yet it was enabled by default. (Thanks Microsoft....) Specifically, it's a failure to link to functions like __atomic_store_8, __atomic_load_8, __atomic_fetch_add_8, etc. Let's just disable it. Someone who really needs this for developing can have CMake with the debugger on their host machine or manually re-enable it here. Link: https://gitlab.kitware.com/cmake/cmake/-/issues/21510 Link: https://devblogs.microsoft.com/cppblog/cmake-debugger-allows-you-to-debug-your-cmake-scripts-and-more/ Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index 813e484915..19c4a5b8b8 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -30,6 +30,7 @@ HOST_CONFIGURE_VARS += \
MAKE="$(STAGING_DIR_HOST)/bin/ninja"
HOST_CONFIGURE_ARGS := \
+ --no-debugger \
$(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)") \
--prefix="$(STAGING_DIR_HOST)" \
--system-expat \