summaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-11-22 00:38:36 -0800
committerHans Dedecker <dedeckeh@gmail.com>2021-11-26 21:27:50 +0100
commita18047de45679fb21129d265c1e449dcaee02ce6 (patch)
tree9f1e90e16f9ddebbbf7b1a3e15ea90d16c0096d1 /tools/cmake
parentfb6c34d355e19152550a8347cde13e1c359f1aca (diff)
downloadopenwrt-a18047de45679fb21129d265c1e449dcaee02ce6.tar.gz
openwrt-a18047de45679fb21129d265c1e449dcaee02ce6.tar.bz2
openwrt-a18047de45679fb21129d265c1e449dcaee02ce6.zip
tools/cmake: update to 3.22.0
Refreshed patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/Makefile4
-rw-r--r--tools/cmake/patches/120-curl-fix-libressl-linking.patch2
-rw-r--r--tools/cmake/patches/130-bootstrap_parallel_make_flag.patch2
3 files changed, 4 insertions, 4 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index df61c83158..9819176713 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -7,14 +7,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
-PKG_VERSION:=3.21.3
+PKG_VERSION:=3.22.0
PKG_RELEASE:=1
PKG_CPE_ID:=cpe:/a:kitware:cmake
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/Kitware/CMake/releases/download/v$(PKG_VERSION)/ \
https://cmake.org/files/v3.19/
-PKG_HASH:=d14d06df4265134ee42c4d50f5a60cb8b471b7b6a47da8e5d914d49dd783794f
+PKG_HASH:=998c7ba34778d2dfdb3df8a695469e24b11e2bfa21fbe41b361a3f45e1c9345e
HOST_BUILD_PARALLEL:=1
HOST_CONFIGURE_PARALLEL:=1
diff --git a/tools/cmake/patches/120-curl-fix-libressl-linking.patch b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
index 97ef5ceb00..fd05d106c8 100644
--- a/tools/cmake/patches/120-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
@@ -20,7 +20,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -528,6 +528,14 @@ if(CMAKE_USE_OPENSSL)
+@@ -565,6 +565,14 @@ if(CMAKE_USE_OPENSSL)
endif()
set(SSL_ENABLED ON)
set(USE_OPENSSL ON)
diff --git a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
index 3822cba166..dd66989c98 100644
--- a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
+++ b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
@@ -1,6 +1,6 @@
--- a/bootstrap
+++ b/bootstrap
-@@ -1420,7 +1420,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1423,7 +1423,10 @@ int main(){ printf("1%c", (char)0x0a); r
' > "test.c"
cmake_original_make_flags="${cmake_make_flags}"
if test "x${cmake_parallel_make}" != "x"; then