summaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorPiotr Stefaniak <pstef@freebsd.org>2020-08-09 00:38:21 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-10 00:01:51 +0200
commite27fbae63c3436ce5588ca06b78ea88c7a316fee (patch)
tree34a0a15d600d461885487ee7af66fdc5e8d300ff /tools/cmake
parentc25c9e98f59357df9e92396aba44220d840dba7d (diff)
downloadopenwrt-e27fbae63c3436ce5588ca06b78ea88c7a316fee.tar.gz
openwrt-e27fbae63c3436ce5588ca06b78ea88c7a316fee.tar.bz2
openwrt-e27fbae63c3436ce5588ca06b78ea88c7a316fee.zip
tools/cmake: fix typo in parallel make patch
The variable in the case argument was mistyped, so the case always checked against an empty string and never matched. Fix the variable name. Add a PKG_RELEASE to Makefile so we can bump it. Fixes: d6de31310cc1 ("cmake: restore parallel build support for bootstrap") Signed-off-by: Piotr Stefaniak <pstef@freebsd.org> [add commit message, add PKG_RELEASE, fix commit title, add Fixes:] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/Makefile1
-rw-r--r--tools/cmake/patches/130-bootstrap_parallel_make_flag.patch2
2 files changed, 2 insertions, 1 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index ab3d225aa6..fd066da326 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -8,6 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
PKG_VERSION:=3.17.0
+PKG_RELEASE:=2
PKG_CPE_ID:=cpe:/a:kitware:cmake
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
index 7b6198b14b..45ad885953 100644
--- a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
+++ b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
@@ -5,7 +5,7 @@
cmake_original_make_flags="${cmake_make_flags}"
if [ "x${cmake_parallel_make}" != "x" ]; then
- cmake_make_flags="${cmake_make_flags} -j ${cmake_parallel_make}"
-+ case "$cmake_paralle_make" in
++ case "$cmake_parallel_make" in
+ [0-9]*) cmake_parallel_make="-j ${cmake_parallel_make}";;
+ esac
+ cmake_make_flags="${cmake_make_flags} ${cmake_parallel_make}"