summaryrefslogtreecommitdiffstats
path: root/tools/coreutils/Makefile
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-09-04 18:59:51 -0400
committerRobert Marko <robimarko@gmail.com>2024-04-25 21:33:51 +0200
commit0489436506f20207dc2177fc30e84f7fb0cc9d07 (patch)
tree55b6efce0bdf860dfbfde36101fbe05cb992239f /tools/coreutils/Makefile
parent41bc16dcc4594cd85fb87942032dcbec0ade7068 (diff)
downloadopenwrt-0489436506f20207dc2177fc30e84f7fb0cc9d07.tar.gz
openwrt-0489436506f20207dc2177fc30e84f7fb0cc9d07.tar.bz2
openwrt-0489436506f20207dc2177fc30e84f7fb0cc9d07.zip
tools/coreutils: update to 9.4
Update to latest stable release. Add configure option to disable support for the Year 2038 problem. (for now, as some versions of GCC do not yet support it) Syncing bootstrap script fails, backport an upstream patch which can be removed at next coreutils update. Several headers from the stable gnulib branch cause build failure because the changes in the imported versions are incompatible with the Makefile that gets generated for coreutils. This version of coreutils was released after being bootstrapped and autoreconf'ed with a significantly different version of gnulib compared to our local gnulib, so skip importing them (and restore the backup). While at it, organize restoring the originally shipped version of files into a Make foreach function. Refresh patch: - 000-bootstrap.patch New patch: - 001-bootstrap-sync.patch Link: https://lists.gnu.org/archive/html/coreutils/2023-08/msg00099.html Tested-by: Georgi Valkov <gvalkov@gmail.com> # MacOS Signed-off-by: Michael Pratt <mcpratt@pm.me> Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'tools/coreutils/Makefile')
-rw-r--r--tools/coreutils/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/tools/coreutils/Makefile b/tools/coreutils/Makefile
index 69d1dcbd37..184281f0be 100644
--- a/tools/coreutils/Makefile
+++ b/tools/coreutils/Makefile
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=coreutils
PKG_CPE_ID:=cpe:/a:gnu:coreutils
-PKG_VERSION:=9.3
+PKG_VERSION:=9.4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/coreutils
-PKG_HASH:=a33d2c0bc49be3c79a4794944dcd87103bf497b53a14bafcd431c8ca53975252
+PKG_HASH:=5f600d9093973b0afe25393d9bc18c44f2232657f4ca0d95ea31c702eb66b739
HOST_BUILD_PARALLEL := 1
@@ -22,7 +22,17 @@ include $(INCLUDE_DIR)/host-build.mk
export GNULIB_SRCDIR:=$(HOST_GNULIB_SRCDIR)
+HOST_GNULIB_SKIP := \
+ lib/math.in.h \
+ lib/stdlib.in.h \
+ lib/string.in.h \
+ lib/uchar.in.h \
+ lib/unistd.in.h \
+ lib/wchar.in.h \
+ lib/wctype.in.h
+
HOST_CONFIGURE_ARGS += \
+ --disable-year2038 \
--enable-install-program=$(subst $(space),$(comma),$(strip $(PKG_PROGRAMS)))
HOST_MAKE_FLAGS += \
@@ -50,7 +60,7 @@ endef
define Host/Configure
$(if $(QUILT),$(call Host/Bootstrap))
- -$(CP) $(HOST_BUILD_DIR)/lib/time.in.h~ $(HOST_BUILD_DIR)/lib/time.in.h # @GNULIB_TIME@ not defined
+ $(foreach src,$(HOST_GNULIB_SKIP),mv -f $(HOST_BUILD_DIR)/$(src)~ $(HOST_BUILD_DIR)/$(src) || true; )
$(call Host/Configure/Default)
endef