summaryrefslogtreecommitdiffstats
path: root/tools/coreutils/Makefile
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-05-30 05:22:54 -0400
committerPetr Štetiar <ynezz@true.cz>2023-06-05 08:31:56 +0200
commit14a85d929b4a0a728dc4390ad34dcf8d69ac3475 (patch)
tree0d1028d665aee129c77b11ea9ee894df3eb2404a /tools/coreutils/Makefile
parent04053e3f2050b6ea2cdb83c0956034e5fd368d10 (diff)
downloadopenwrt-14a85d929b4a0a728dc4390ad34dcf8d69ac3475.tar.gz
openwrt-14a85d929b4a0a728dc4390ad34dcf8d69ac3475.tar.bz2
openwrt-14a85d929b4a0a728dc4390ad34dcf8d69ac3475.zip
tools/coreutils: rename list of installed programs
Rename the list of programs installed by coreutils to PKG_PROGRAMS, which will create a stampfile for each through a new feature in host-build.mk. Also, cleanup a bit to save lines regarding the usage of this list. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'tools/coreutils/Makefile')
-rw-r--r--tools/coreutils/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/tools/coreutils/Makefile b/tools/coreutils/Makefile
index 233ab1585d..8630286206 100644
--- a/tools/coreutils/Makefile
+++ b/tools/coreutils/Makefile
@@ -16,20 +16,18 @@ PKG_HASH:=adbcfcfe899235b71e8768dcf07cd532520b7f54f9a8064843f8d199a904bbaa
HOST_BUILD_PARALLEL := 1
-BUILD_PROGRAMS = date readlink touch ln chown ginstall
+PKG_PROGRAMS:=date readlink touch ln chown ginstall
include $(INCLUDE_DIR)/host-build.mk
export GNULIB_SRCDIR:=$(HOST_GNULIB_SRCDIR)
-BUILD_BINS = $(patsubst %,src/%,$(BUILD_PROGRAMS))
-
HOST_CONFIGURE_ARGS += \
- --enable-install-program=$(subst $(space),$(comma),$(strip $(BUILD_PROGRAMS)))
+ --enable-install-program=$(subst $(space),$(comma),$(strip $(PKG_PROGRAMS)))
HOST_MAKE_FLAGS += \
$(AM_TOOL_PATHS_FAKE) \
- PROGRAMS="$(BUILD_BINS)" \
+ PROGRAMS="$(patsubst %,src/%,$(PKG_PROGRAMS))" \
LIBRARIES= MANS= SUBDIRS=.
define Host/Bootstrap
@@ -58,7 +56,7 @@ endef
define Host/Install
$(INSTALL_DIR) $(1)/bin
- $(INSTALL_BIN) $(patsubst %,$(HOST_BUILD_DIR)/%,$(BUILD_BINS)) $(1)/bin/
+ $(INSTALL_BIN) $(patsubst %,$(HOST_BUILD_DIR)/src/%,$(PKG_PROGRAMS)) $(1)/bin/
ln -sf ginstall $(1)/bin/install
endef