summaryrefslogtreecommitdiffstats
path: root/tools/coreutils/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-07-13 17:48:31 +0200
committerFelix Fietkau <nbd@nbd.name>2022-07-13 17:57:34 +0200
commit9dc86d19628f55bfed2048c412c5b23bda328cff (patch)
treeb369fa75f69971bd629be80d2a045c9ba9aaf5df /tools/coreutils/Makefile
parente0e74d8a2ced19f46428d30efd388db72d79326b (diff)
downloadopenwrt-9dc86d19628f55bfed2048c412c5b23bda328cff.tar.gz
openwrt-9dc86d19628f55bfed2048c412c5b23bda328cff.tar.bz2
openwrt-9dc86d19628f55bfed2048c412c5b23bda328cff.zip
tools/coreutils: enable ginstall utility
For some reason, current coreutils version installed on x86 macOS via homebrew have a bug, where at least the cc1 binary from gcc gets corrupted during install to the staging dir. Using the install utility from tools/coreutils fixes this Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/coreutils/Makefile')
-rw-r--r--tools/coreutils/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/tools/coreutils/Makefile b/tools/coreutils/Makefile
index fc5c259d8f..87c9102fa6 100644
--- a/tools/coreutils/Makefile
+++ b/tools/coreutils/Makefile
@@ -16,7 +16,7 @@ PKG_HASH:=4458d8de7849df44ccab15e16b1548b285224dbba5f08fac070c1c0e0bcc4cfa
HOST_BUILD_PARALLEL := 1
-BUILD_PROGRAMS = date readlink touch ln chown
+BUILD_PROGRAMS = date readlink touch ln chown ginstall
include $(INCLUDE_DIR)/host-build.mk
@@ -31,7 +31,8 @@ HOST_MAKE_FLAGS += \
define Host/Install
$(INSTALL_DIR) $(1)/bin
- $(CP) $(patsubst %,$(HOST_BUILD_DIR)/%,$(BUILD_BINS)) $(1)/bin/
+ $(INSTALL_BIN) $(patsubst %,$(HOST_BUILD_DIR)/%,$(BUILD_BINS)) $(1)/bin/
+ ln -sf ginstall $(1)/bin/install
endef
$(eval $(call HostBuild))