summaryrefslogtreecommitdiffstats
path: root/tools/cpio
diff options
context:
space:
mode:
authorLinhui Liu <liulinhui36@gmail.com>2023-05-07 15:28:32 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-05-09 11:38:18 +0200
commit3636b06b2d05de0d5a29c68f390d10bc52666f3c (patch)
treee634b90d586edca3ebc988b8acfe89ea9c94bb3c /tools/cpio
parent9207c728509e73c193efe7bbe74026edf9cef949 (diff)
downloadopenwrt-3636b06b2d05de0d5a29c68f390d10bc52666f3c.tar.gz
openwrt-3636b06b2d05de0d5a29c68f390d10bc52666f3c.tar.bz2
openwrt-3636b06b2d05de0d5a29c68f390d10bc52666f3c.zip
tools/cpio: update to 2.14
Noteworthy changes in this release: * New option --ignore-dirnlink Valid in copy-out mode, it instructs cpio to ignore the actual number of links reported for each directory member and always store 2 instead. * Changes in --reproducible option The --reproducible option implies --ignore-dirlink. In other words, it is equivalent to --ignore-devno --ignore-dirnlink --renumber-inodes. * Use GNU ls algorithm for deciding timestamp format in -tv mode * Bugfixes ** Fix cpio header verification. ** Fix handling of device numbers on copy out. ** Fix calculation of CRC in copy-out mode. ** Rewrite the fix for CVE-2015-1197. ** Fix combination of --create --append --directory. ** Fix appending to archives bigger than 2G. Removed upstreamed: - 001-duplicate-program-name.patch - 010-clang.patch Signed-off-by: Linhui Liu <liulinhui36@gmail.com>
Diffstat (limited to 'tools/cpio')
-rw-r--r--tools/cpio/Makefile4
-rw-r--r--tools/cpio/patches/001-duplicate-program-name.patch18
-rw-r--r--tools/cpio/patches/010-clang.patch11
3 files changed, 2 insertions, 31 deletions
diff --git a/tools/cpio/Makefile b/tools/cpio/Makefile
index 82b5aa8365..1550785ddc 100644
--- a/tools/cpio/Makefile
+++ b/tools/cpio/Makefile
@@ -3,11 +3,11 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cpio
PKG_CPE_ID:=cpe:/a:gnu:cpio
-PKG_VERSION:=2.13
+PKG_VERSION:=2.14
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@GNU/cpio
-PKG_HASH:=eab5bdc5ae1df285c59f2a4f140a98fc33678a0bf61bdba67d9436ae26b46f6d
+PKG_HASH:=fcdc15d60f7267a6fc7efcd6b9db7b6c8966c4f2fbbb964c24d41336fd3f2c12
include $(INCLUDE_DIR)/host-build.mk
diff --git a/tools/cpio/patches/001-duplicate-program-name.patch b/tools/cpio/patches/001-duplicate-program-name.patch
deleted file mode 100644
index a7c3fbc8ae..0000000000
--- a/tools/cpio/patches/001-duplicate-program-name.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-author Sergey Poznyakoff <gray@gnu.org>
-
-https://git.savannah.gnu.org/cgit/cpio.git/commit/?id=641d3f489cf6238bb916368d4ba0d9325a235afb
-
-* src/global.c: Remove superfluous declaration of program_name
-
---- a/src/global.c
-+++ b/src/global.c
-@@ -184,9 +184,6 @@ unsigned int warn_option = 0;
- /* Extract to standard output? */
- bool to_stdout_option = false;
-
--/* The name this program was run with. */
--char *program_name;
--
- /* A pointer to either lstat or stat, depending on whether
- dereferencing of symlinks is done for input files. */
- int (*xstat) ();
diff --git a/tools/cpio/patches/010-clang.patch b/tools/cpio/patches/010-clang.patch
deleted file mode 100644
index 89c7a8149e..0000000000
--- a/tools/cpio/patches/010-clang.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/gnu/xalloc-oversized.h
-+++ b/gnu/xalloc-oversized.h
-@@ -52,7 +52,7 @@ typedef size_t __xalloc_count_type;
- #elif ((5 <= __GNUC__ \
- || (__has_builtin (__builtin_mul_overflow) \
- && __has_builtin (__builtin_constant_p))) \
-- && !__STRICT_ANSI__)
-+ && !__STRICT_ANSI__) && !defined(__clang__)
- # define xalloc_oversized(n, s) \
- (__builtin_constant_p (n) && __builtin_constant_p (s) \
- ? __xalloc_oversized (n, s) \