summaryrefslogtreecommitdiffstats
path: root/tools/e2fsprogs
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-09-15 15:49:31 +0200
committerFelix Fietkau <nbd@nbd.name>2018-09-15 15:49:43 +0200
commit03c7c8c8530cc899bf04d0559d575ba0ea1de19c (patch)
treee25882b20d0b2ed7fabb68b45e5dada822ed505f /tools/e2fsprogs
parent033f02b9b5580e67e2f1b623f62da60d645e7ba2 (diff)
downloadopenwrt-03c7c8c8530cc899bf04d0559d575ba0ea1de19c.tar.gz
openwrt-03c7c8c8530cc899bf04d0559d575ba0ea1de19c.tar.bz2
openwrt-03c7c8c8530cc899bf04d0559d575ba0ea1de19c.zip
tools/e2fsprogs: fix build with clang
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/e2fsprogs')
-rw-r--r--tools/e2fsprogs/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/e2fsprogs/Makefile b/tools/e2fsprogs/Makefile
index fec6d83454..f11ce52ca0 100644
--- a/tools/e2fsprogs/Makefile
+++ b/tools/e2fsprogs/Makefile
@@ -20,6 +20,9 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+ifneq ($(shell $(HOSTCC) --version | grep clang),)
+ HOST_CFLAGS += -D__GNUC_PREREQ\(...\)=0
+endif
HOST_CFLAGS += $(FPIC)
HOST_CONFIGURE_ARGS += \