summaryrefslogtreecommitdiffstats
path: root/tools/elftosb
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2013-06-26 10:15:29 +0000
committerZoltan Herpai <wigyori@uid0.hu>2013-06-26 10:15:29 +0000
commit82ae24602a1b2c50252bed9e20dec751e780e9e3 (patch)
treee227a94869aabb17433b4995dbd2f1bbdfea7e93 /tools/elftosb
parentcb66ed972bb25e341a659884df598b936b606388 (diff)
downloadopenwrt-82ae24602a1b2c50252bed9e20dec751e780e9e3.tar.gz
openwrt-82ae24602a1b2c50252bed9e20dec751e780e9e3.tar.bz2
openwrt-82ae24602a1b2c50252bed9e20dec751e780e9e3.zip
tools: add tools for i.MX23 boards
SVN-Revision: 37035
Diffstat (limited to 'tools/elftosb')
-rw-r--r--tools/elftosb/Makefile31
-rw-r--r--tools/elftosb/patches/001-libm.patch11
-rw-r--r--tools/elftosb/patches/002-fix-header-path.patch19
3 files changed, 61 insertions, 0 deletions
diff --git a/tools/elftosb/Makefile b/tools/elftosb/Makefile
new file mode 100644
index 0000000000..c063217d0b
--- /dev/null
+++ b/tools/elftosb/Makefile
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=elftosb
+PKG_VERSION:=10.12.01
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://repository.timesys.com/buildsources/e/elftosb/elftosb-10.12.01/
+PKG_MD5SUM:=e8005d606c1e0bb3507c82f6eceb3056
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) -f makefile LDFLAGS="$(HOST_STATIC_LINKING)"
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/bld/linux/elftosb $(STAGING_DIR_HOST)/bin/elftosb
+endef
+
+define Host/Clean
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/elftosb/patches/001-libm.patch b/tools/elftosb/patches/001-libm.patch
new file mode 100644
index 0000000000..02705d24bb
--- /dev/null
+++ b/tools/elftosb/patches/001-libm.patch
@@ -0,0 +1,11 @@
+--- elftosb-10.12.01/makefile.rules 2012-03-15 11:01:44.979020178 -0400
++++ elftosb-10.12.01/makefile.rules 2012-03-15 11:01:16.332761989 -0400
+@@ -101,7 +101,7 @@
+ keygen.o
+
+
+-LIBS = -lstdc++
++LIBS = -lstdc++ -lm
+
+
+ ifeq ("${UNAMES}", "Linux")
diff --git a/tools/elftosb/patches/002-fix-header-path.patch b/tools/elftosb/patches/002-fix-header-path.patch
new file mode 100644
index 0000000000..5e3b5091b9
--- /dev/null
+++ b/tools/elftosb/patches/002-fix-header-path.patch
@@ -0,0 +1,19 @@
+This package had an absolute path for sys/types.h, which doesn't
+make much sense. It breaks on newer Ubuntu systems, and probably many
+others once multiarch becomes more common.
+
+This patch makes the types a relative path, and allows the system
+to use whatever include paths it feels are correct.
+
+diff -Naurp elftosb-10.12.01-orig/common/stdafx.h elftosb-10.12.01/common/stdafx.h
+--- elftosb-10.12.01-orig/common/stdafx.h 2012-07-12 13:30:10.990249396 -0400
++++ elftosb-10.12.01/common/stdafx.h 2012-07-12 13:30:06.858249391 -0400
+@@ -27,7 +27,7 @@
+ // For Linux systems only, types.h only defines the signed
+ // integer types. This is not professional code.
+ // Update: They are defined in the header files in the more recent version of redhat enterprise gcc.
+-#include "/usr/include/sys/types.h"
++#include <sys/types.h>
+ #include <stdint.h>
+ //typedef unsigned long uint32_t;
+ //typedef unsigned short uint16_t;