summaryrefslogtreecommitdiffstats
path: root/tools/elfutils/Makefile
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2024-03-03 21:04:36 -0800
committerRobert Marko <robimarko@gmail.com>2024-04-25 21:33:51 +0200
commitb6f025b42429ec809afeb0956b35535c248b6c1b (patch)
treef799f44dd9f3e64713ce35a3e1796774ce6dd9b2 /tools/elfutils/Makefile
parent44625e9d95882a3d868df2c83d304fc32cc5afc0 (diff)
downloadopenwrt-b6f025b42429ec809afeb0956b35535c248b6c1b.tar.gz
openwrt-b6f025b42429ec809afeb0956b35535c248b6c1b.tar.bz2
openwrt-b6f025b42429ec809afeb0956b35535c248b6c1b.zip
tools/elfutils: update to 1.91
Release Notes: https://sourceware.org/pipermail/elfutils-devel/2024q1/006876.html Manually refresh: - 100-portability.patch Change: - replace libgen.h with gnulib "dirname" module for compilation errors: In file included from ./../libdw/libdwP.h:38, from eblobjnote.c:42: /usr/include/libgen.h:35:9: error: attempt to use poisoned "basename" 35 | #define basename __xpg_basename | ^ Tested-by: Georgi Valkov <gvalkov@gmail.com> # MacOS Co-Developed-by: Nick Hainke <vincent@systemli.org> Signed-off-by: Nick Hainke <vincent@systemli.org> Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'tools/elfutils/Makefile')
-rw-r--r--tools/elfutils/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/elfutils/Makefile b/tools/elfutils/Makefile
index a701827248..adf8770783 100644
--- a/tools/elfutils/Makefile
+++ b/tools/elfutils/Makefile
@@ -3,12 +3,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=elfutils
-PKG_VERSION:=0.189
+PKG_VERSION:=0.191
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://sourceware.org/$(PKG_NAME)/ftp/$(PKG_VERSION)
-PKG_HASH:=39bd8f1a338e2b7cd4abc3ff11a0eddc6e690f69578a57478d8179b4148708c8
+PKG_HASH:=df76db71366d1d708365fc7a6c60ca48398f14367eb2b8954efc8897147ad871
PKG_LICENSE:=GPL-3.0-or-later
PKG_LICENSE_FILES:=COPYING COPYING-GPLV2 COPYING-LGPLV3
@@ -43,7 +43,7 @@ endif
Hooks/HostConfigure/Pre := Host/Gnulib $(Hooks/HostConfigure/Pre)
define Host/Gnulib
- cd $(HOST_BUILD_DIR); $(STAGING_DIR_HOST)/bin/gnulib-tool --libtool --source-base=libgnu --import argp obstack fts strchrnul progname tsearch;
+ cd $(HOST_BUILD_DIR); $(STAGING_DIR_HOST)/bin/gnulib-tool --libtool --source-base=libgnu --import argp dirname fts obstack progname strchrnul tsearch;
ln -sf ../lib/eu-config.h $(HOST_BUILD_DIR)/libgnu/;
endef