summaryrefslogtreecommitdiffstats
path: root/tools/elfutils
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-03-28 18:40:30 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2022-05-18 13:32:06 +0300
commitad79b92719498afa93567cccdfbffeb49a57388d (patch)
treeed9964683f4a24f9f33da06619a65a914a94c104 /tools/elfutils
parentd5dc6cdc536277ce1831acce92dc1cbdc59e7250 (diff)
downloadopenwrt-ad79b92719498afa93567cccdfbffeb49a57388d.tar.gz
openwrt-ad79b92719498afa93567cccdfbffeb49a57388d.tar.bz2
openwrt-ad79b92719498afa93567cccdfbffeb49a57388d.zip
elfutils: move host build to tools
The upcoming dwarves host package requires elfutils. As dependencies for tools must exist in tools, we need to move elfutils host build there. As there is at least one package that depends on this, and there is no proper way to create such dependency in the build system, build it unconditionally when not building on macOS. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'tools/elfutils')
-rw-r--r--tools/elfutils/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/tools/elfutils/Makefile b/tools/elfutils/Makefile
new file mode 100644
index 0000000000..98694beb0e
--- /dev/null
+++ b/tools/elfutils/Makefile
@@ -0,0 +1,32 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=elfutils
+PKG_VERSION:=0.186
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://sourceware.org/$(PKG_NAME)/ftp/$(PKG_VERSION)
+PKG_HASH:=7f6fb9149b1673d38d9178a0d3e0fb8a1ec4f53a9f4c2ff89469609879641177
+
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=COPYING COPYING-GPLV2 COPYING-LGPLV3
+PKG_CPE_ID:=cpe:/a:elfutils_project:elfutils
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+HOST_BUILD_DEPENDS:=argp-standalone/host musl-fts/host
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+ --disable-debuginfod \
+ --disable-libdebuginfod \
+ --disable-nls \
+ --disable-shared \
+ --without-lzma \
+ --without-zstd
+
+$(eval $(call HostBuild))