summaryrefslogtreecommitdiffstats
path: root/tools/elfutils
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-05-19 01:53:49 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2022-05-19 02:36:48 +0300
commitf64bd4b6cef3b9a57f26928c1b8932534695cb72 (patch)
tree795995ca54ef7007d8dc0f1fbc14db01a3227f0a /tools/elfutils
parent16e9ccd5fa39f3a32bca65831a881d9376d921bd (diff)
downloadopenwrt-f64bd4b6cef3b9a57f26928c1b8932534695cb72.tar.gz
openwrt-f64bd4b6cef3b9a57f26928c1b8932534695cb72.tar.bz2
openwrt-f64bd4b6cef3b9a57f26928c1b8932534695cb72.zip
tools/elfutils: only build required components
Building all of the components results in strip being installed in staging_dir/host/bin. This strip binary will take precedence over binutils strip that is installed in the toolchain directory. This will not work on host systems that do not have libdw installed, as we do not set HOST_LDFLAGS to override rpath to staging_dir/host/lib. However, rather than overriding rpath, we should just avoid using elfutils strip entirely. Override the SUBDIRS variable in the Makefile to only build and install the libraries we require for dwarves and frr. Fixes the following build failure in toolchain/gdb: strip: error while loading shared libraries: libdw.so.1: cannot open shared object file: No such file or directory Fixes: ad79b9271949 ("elfutils: move host build to tools") Reported-by: Dominick Grift <dominick.grift@defensec.nl> Reported-by: Lucian Cristian <lucian.cristian@gmail.com> Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'tools/elfutils')
-rw-r--r--tools/elfutils/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/elfutils/Makefile b/tools/elfutils/Makefile
index 98694beb0e..2f4dd8f253 100644
--- a/tools/elfutils/Makefile
+++ b/tools/elfutils/Makefile
@@ -29,4 +29,7 @@ HOST_CONFIGURE_ARGS += \
--without-lzma \
--without-zstd
+HOST_MAKE_FLAGS += \
+ SUBDIRS="lib libelf libcpu backends libebl libdwelf libdwfl libdw"
+
$(eval $(call HostBuild))