summaryrefslogtreecommitdiffstats
path: root/tools/flex
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-12 10:47:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-12 10:47:31 +0000
commit8087fa9e045d4c9ff12eaba6f65b1ba0b0364054 (patch)
tree8e2bbf3c31ed7e298cf4b28fe21997dfce13c68d /tools/flex
parent73d9ad0c952ae6257f3ce01115f91c3485bb4778 (diff)
downloadopenwrt-8087fa9e045d4c9ff12eaba6f65b1ba0b0364054.tar.gz
openwrt-8087fa9e045d4c9ff12eaba6f65b1ba0b0364054.tar.bz2
openwrt-8087fa9e045d4c9ff12eaba6f65b1ba0b0364054.zip
flex: fix build error due to undefined library symbols
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 39888
Diffstat (limited to 'tools/flex')
-rw-r--r--tools/flex/patches/100-remove_no_undefined.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/tools/flex/patches/100-remove_no_undefined.patch b/tools/flex/patches/100-remove_no_undefined.patch
new file mode 100644
index 0000000000..4e8aca13c7
--- /dev/null
+++ b/tools/flex/patches/100-remove_no_undefined.patch
@@ -0,0 +1,18 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -73,13 +73,13 @@ libfl_la_SOURCES = \
+ libmain.c \
+ libyywrap.c
+
+-libfl_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libfl_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
+
+ libfl_pic_la_SOURCES = \
+ libmain.c \
+ libyywrap.c
+
+-libfl_pic_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libfl_pic_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
+
+ noinst_HEADERS = \
+ flexdef.h \