summaryrefslogtreecommitdiffstats
path: root/tools/flex
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-03-25 01:01:36 -0400
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-04 06:07:28 +0200
commite764a909e3d468a5597373cac087ecc008540e2d (patch)
tree7b4736fe5de076334d3351bbc215d32c0c7d930d /tools/flex
parent89a8269c109b56364bc5c7a63afb8e2888ba9143 (diff)
downloadopenwrt-e764a909e3d468a5597373cac087ecc008540e2d.tar.gz
openwrt-e764a909e3d468a5597373cac087ecc008540e2d.tar.bz2
openwrt-e764a909e3d468a5597373cac087ecc008540e2d.zip
tools/flex: override SUBDIRS variable with Makefile
Instead of editing the SUBDIRS variable with a patch, it can be overriden at the end of the command line when invoking Make. Skip the build for po files as well, which is causing a conflict depending on the version of gettext detected, and macros present. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'tools/flex')
-rw-r--r--tools/flex/Makefile8
-rw-r--r--tools/flex/patches/100-disable-tests-docs.patch13
2 files changed, 6 insertions, 15 deletions
diff --git a/tools/flex/Makefile b/tools/flex/Makefile
index da037ae72d..86ba5a4415 100644
--- a/tools/flex/Makefile
+++ b/tools/flex/Makefile
@@ -21,13 +21,17 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += --disable-shared
+define Host/Compile
+ $(call Host/Compile/Default,SUBDIRS='src tools')
+endef
+
define Host/Install
- $(call Host/Install/Default)
+ $(call Host/Compile/Default,install SUBDIRS='src tools')
$(LN) flex $(STAGING_DIR_HOST)/bin/lex
endef
define Host/Uninstall
- -$(call Host/Compile/Default,uninstall)
+ -$(call Host/Compile/Default,uninstall SUBDIRS='src tools')
endef
define Host/Clean
diff --git a/tools/flex/patches/100-disable-tests-docs.patch b/tools/flex/patches/100-disable-tests-docs.patch
deleted file mode 100644
index f7097f2127..0000000000
--- a/tools/flex/patches/100-disable-tests-docs.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -43,10 +43,7 @@ EXTRA_DIST = \
-
- SUBDIRS = \
- src \
-- doc \
-- examples \
- po \
-- tests \
- tools
-
- # Create the ChangeLog, but only if we're inside a git working directory