summaryrefslogtreecommitdiffstats
path: root/tools/flock
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-28 01:23:56 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-20 00:33:22 +0200
commita63805b25f99e609d575ee920baae269fb58794c (patch)
tree3d7090484571e2b300efdd658033378c250a485e /tools/flock
parentf2ae4e2f8cf698f6fc6ae802dae86f50916f4286 (diff)
downloadopenwrt-a63805b25f99e609d575ee920baae269fb58794c.tar.gz
openwrt-a63805b25f99e609d575ee920baae269fb58794c.tar.bz2
openwrt-a63805b25f99e609d575ee920baae269fb58794c.zip
tools: add Host/Uninstall where possible
This cleans staging_dir when calling tool/x/clean. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/flock')
-rw-r--r--tools/flock/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/flock/Makefile b/tools/flock/Makefile
index cd3561bb69..4e0a45440f 100644
--- a/tools/flock/Makefile
+++ b/tools/flock/Makefile
@@ -24,4 +24,8 @@ define Host/Install
$(INSTALL_BIN) $(HOST_BUILD_DIR)/flock $(STAGING_DIR_HOST)/bin/
endef
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/flock
+endef
+
$(eval $(call HostBuild))