summaryrefslogtreecommitdiffstats
path: root/tools/gengetopt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-11-30 20:12:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-11-30 20:12:07 +0000
commit2311cfeed4cf7b66f7360993017d9e4a920f6559 (patch)
treee63e90abd90306d90132229495298550f785cb63 /tools/gengetopt
parent47f09fd3456ae3e03ee667ce231d90e350443e57 (diff)
downloadopenwrt-2311cfeed4cf7b66f7360993017d9e4a920f6559.tar.gz
openwrt-2311cfeed4cf7b66f7360993017d9e4a920f6559.tar.bz2
openwrt-2311cfeed4cf7b66f7360993017d9e4a920f6559.zip
gengetopt: fix parallel build issues (#18442)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43440
Diffstat (limited to 'tools/gengetopt')
-rw-r--r--tools/gengetopt/Makefile2
-rw-r--r--tools/gengetopt/patches/100-dependency_fix.patch11
2 files changed, 13 insertions, 0 deletions
diff --git a/tools/gengetopt/Makefile b/tools/gengetopt/Makefile
index a66fbe6605..74e528e6fd 100644
--- a/tools/gengetopt/Makefile
+++ b/tools/gengetopt/Makefile
@@ -13,6 +13,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
PKG_MD5SUM:=29749a48dda69277ab969c510597a14e
+HOST_FIXUP := autoreconf
+
HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
diff --git a/tools/gengetopt/patches/100-dependency_fix.patch b/tools/gengetopt/patches/100-dependency_fix.patch
new file mode 100644
index 0000000000..69cb598b7d
--- /dev/null
+++ b/tools/gengetopt/patches/100-dependency_fix.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -51,7 +51,7 @@ libgengetopt_la_LIBADD = $(top_builddir)
+ @LTLIBOBJS@ \
+ skels/libgen.la
+
+-LDADD = $(top_builddir)/src/libgengetopt.la
++LDADD = libgengetopt.la
+
+ EXTRA_DIST = parser.h argsdef.h gengetopt.h ggos.h gm.h gnugetopt.h \
+ cmdline.c cmdline.h \