summaryrefslogtreecommitdiffstats
path: root/tools/gnulib
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-03-22 18:46:30 -0400
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-04 06:07:27 +0200
commite4977f614ffa2aaaaba0b5944747848b5b02f25a (patch)
treea042b147dcbd3c529d117343541b8a79c202a65b /tools/gnulib
parentfe33d5ba13370027165b9acf2bd895f5b4d9a4ea (diff)
downloadopenwrt-e4977f614ffa2aaaaba0b5944747848b5b02f25a.tar.gz
openwrt-e4977f614ffa2aaaaba0b5944747848b5b02f25a.tar.bz2
openwrt-e4977f614ffa2aaaaba0b5944747848b5b02f25a.zip
tools/missing-macros: prefer macros provided by gnulib source
These 7 macro files are provided by gnulib, so we can now replace these statically stored copies with the latest copy from GNU sources. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'tools/gnulib')
-rw-r--r--tools/gnulib/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/gnulib/Makefile b/tools/gnulib/Makefile
index c5b7e78c54..43d86c213c 100644
--- a/tools/gnulib/Makefile
+++ b/tools/gnulib/Makefile
@@ -14,6 +14,8 @@ define Host/Configure
endef
define Host/Install
+ $(INSTALL_DIR) $(1)/share/aclocal
+ $(INSTALL_DATA) $(HOST_BUILD_DIR)/m4/*.m4 $(1)/share/aclocal/
$(INSTALL_DIR) $(1)/share/gnulib
$(CP) $(HOST_BUILD_DIR)/* $(1)/share/gnulib/
endef