summaryrefslogtreecommitdiffstats
path: root/tools/libdeflate
diff options
context:
space:
mode:
authorMarkus Stockhausen <markus.stockhausen@gmx.de>2022-07-26 13:44:48 +0200
committerSander Vanheule <sander@svanheule.net>2023-01-02 10:15:37 +0100
commita51ca085bff2f8c6155f18bb767fe2d053bbc90d (patch)
tree1ecf0faa57f26f0fff8e7b97c0afcbc35bba5ba3 /tools/libdeflate
parentc9a7c00f809f6a0a49b600e0ea4f060dfcd0f11f (diff)
downloadopenwrt-a51ca085bff2f8c6155f18bb767fe2d053bbc90d.tar.gz
openwrt-a51ca085bff2f8c6155f18bb767fe2d053bbc90d.tar.bz2
openwrt-a51ca085bff2f8c6155f18bb767fe2d053bbc90d.zip
tools: Add gzip-libdeflate advanced compressor
Several devices provide U-Boot versions with only gzip compressed kernel support (e.g. Realtek switches). This compression method produces larger images than lzma. To save space on flash and avoid going the hard way with lzma-loader we can make use of enhanced gzip tool based on libdeflate compression library from https://github.com/ebiggers/libdeflate. It keeps 100% deflate/gzip compatibility while improving compression ratio. The image can be unpacked by the default inflate routines inside U-Boot. Signed-off-by: Markus Stockhausen <markus.stockhausen@gmx.de> [Switched to v1.15 and made it work with cmake] Signed-off-by: Olliver Schinagl <oliver@schinagl.nl> Reviewed-by: Robert Marko <robimarko@gmail.com> Reviewed-by: Rosen Penev <rosenp@gmail.com> Reviewed-by: Sander Vanheule <sander@svanheule.net>
Diffstat (limited to 'tools/libdeflate')
-rw-r--r--tools/libdeflate/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/tools/libdeflate/Makefile b/tools/libdeflate/Makefile
new file mode 100644
index 0000000000..d30a8ca674
--- /dev/null
+++ b/tools/libdeflate/Makefile
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2022 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libdeflate
+PKG_VERSION:=1.15
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://github.com/ebiggers/libdeflate.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=v$(PKG_VERSION)
+PKG_MIRROR_HASH:=122feff4543541b547dc89e832adf262c81911ae1acbccdc591f0353a85b600a
+
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/programs/libdeflate-gzip $(STAGING_DIR_HOST)/bin/
+ $(LN) libdeflate-gzip $(STAGING_DIR_HOST)/bin/libdeflate-gunzip
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/libdeflate-gzip
+ rm -f $(STAGING_DIR_HOST)/bin/libdeflate-gunzip
+endef
+
+$(eval $(call HostBuild))