summaryrefslogtreecommitdiffstats
path: root/tools/libressl
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-01-10 22:10:59 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-01-10 22:15:37 +0100
commit96a940308bc787fe24447ccb8d0aca0befc74736 (patch)
tree89b141105ee418881f3e8af9a3fb0b8fbb47b3a0 /tools/libressl
parent77beaf2ec91bba0a0202ea63877ed3b399effabf (diff)
downloadopenwrt-96a940308bc787fe24447ccb8d0aca0befc74736.tar.gz
openwrt-96a940308bc787fe24447ccb8d0aca0befc74736.tar.bz2
openwrt-96a940308bc787fe24447ccb8d0aca0befc74736.zip
tools: libressl: always build as PIC
Fixes link errors for host packages like ruby like the following: /usr/bin/ld: .../staging_dir/host/lib/libcrypto.a(libcrypto_la-md5_dgst.o): relocation R_X86_64_PC32 against symbol `memcpy@@GLIBC_2.14' can not be used when making a shared object; recompile with -fPIC Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'tools/libressl')
-rw-r--r--tools/libressl/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/libressl/Makefile b/tools/libressl/Makefile
index 1e3a6f80fb..be6a48be28 100644
--- a/tools/libressl/Makefile
+++ b/tools/libressl/Makefile
@@ -22,5 +22,6 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += --disable-shared
+HOST_CFLAGS += $(FPIC)
$(eval $(call HostBuild))