summaryrefslogtreecommitdiffstats
path: root/tools/libtool/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-13 07:49:10 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-13 07:49:10 +0000
commit90283e410bd6227125427f0f240b87ecd1cc4e1c (patch)
treea3c40fd6e9bdc4f32f3f59fc412162647ae6a62a /tools/libtool/Makefile
parent73a1f3597b0d4ba34306e8ce5f20957f1a1de7f1 (diff)
downloadopenwrt-90283e410bd6227125427f0f240b87ecd1cc4e1c.tar.gz
openwrt-90283e410bd6227125427f0f240b87ecd1cc4e1c.tar.bz2
openwrt-90283e410bd6227125427f0f240b87ecd1cc4e1c.zip
tools: bootstrap libtool to pickup the correct in-tree automake
Also fix 000-relocatable.patch to avoid accidential sed invocations in bootstrap. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 43959
Diffstat (limited to 'tools/libtool/Makefile')
-rw-r--r--tools/libtool/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/tools/libtool/Makefile b/tools/libtool/Makefile
index cb6cf4a5c7..9fab8d94fd 100644
--- a/tools/libtool/Makefile
+++ b/tools/libtool/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -20,6 +20,12 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_VARS += \
lt_cv_sys_dlsearch_path=""
+define Host/Prepare
+ $(call Host/Prepare/Default)
+ (cd $(STAGING_DIR_HOST)/share/aclocal/ && rm -f libtool.m4 ltdl.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4)
+ (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) ./bootstrap)
+endef
+
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install
$(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(STAGING_DIR_HOST)/bin/libtool