summaryrefslogtreecommitdiffstats
path: root/tools/libtool/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-28 01:23:56 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-20 00:33:22 +0200
commita63805b25f99e609d575ee920baae269fb58794c (patch)
tree3d7090484571e2b300efdd658033378c250a485e /tools/libtool/Makefile
parentf2ae4e2f8cf698f6fc6ae802dae86f50916f4286 (diff)
downloadopenwrt-a63805b25f99e609d575ee920baae269fb58794c.tar.gz
openwrt-a63805b25f99e609d575ee920baae269fb58794c.tar.bz2
openwrt-a63805b25f99e609d575ee920baae269fb58794c.zip
tools: add Host/Uninstall where possible
This cleans staging_dir when calling tool/x/clean. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/libtool/Makefile')
-rw-r--r--tools/libtool/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/libtool/Makefile b/tools/libtool/Makefile
index 2bc9db7d0d..fcac06e269 100644
--- a/tools/libtool/Makefile
+++ b/tools/libtool/Makefile
@@ -34,8 +34,11 @@ define Host/Install
$(SED) 's,-lstdc++,-luClibc++,g' $(STAGING_DIR_HOST)/bin/libtool-ucxx
endef
+define Host/Uninstall
+ -$(call Host/Compile/Default,uninstall)
+endef
+
define Host/Clean
- -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
$(call Host/Clean/Default)
endef