summaryrefslogtreecommitdiffstats
path: root/tools/libtool
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-03-15 01:45:02 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2023-03-27 00:41:50 +0200
commit7c0727c26330d12253ec98463279a564ae0f9efa (patch)
tree12d9c75c90cd1ce2f43ba9c1dec6c9c6c139668f /tools/libtool
parent83c1bf2cd43c89c6488cdae2891264593ee8c0c1 (diff)
downloadopenwrt-7c0727c26330d12253ec98463279a564ae0f9efa.tar.gz
openwrt-7c0727c26330d12253ec98463279a564ae0f9efa.tar.bz2
openwrt-7c0727c26330d12253ec98463279a564ae0f9efa.zip
tools/libtool: clean up build recipes
Host/Clean/Default is no longer defined. Use the uninstall makefile target to remove the obsolete m4 files, and more. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'tools/libtool')
-rw-r--r--tools/libtool/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/tools/libtool/Makefile b/tools/libtool/Makefile
index cc9e8a68fb..b4f3ecc36b 100644
--- a/tools/libtool/Makefile
+++ b/tools/libtool/Makefile
@@ -23,7 +23,7 @@ HOST_CONFIGURE_VARS += \
define Host/Prepare
$(call Host/Prepare/Default)
- (cd $(STAGING_DIR_HOST)/share/aclocal/ && rm -f libtool.m4 ltdl.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4)
+ $(call Host/Uninstall)
$(if $(QUILT),,(cd $(HOST_BUILD_DIR); touch README-release; $(AM_TOOL_PATHS) ./bootstrap --skip-git --skip-po --force))
endef
@@ -33,16 +33,13 @@ define Host/Configure
endef
define Host/Install
- $(MAKE) -C $(HOST_BUILD_DIR) install
+ $(call Host/Compile/Default,install)
$(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(STAGING_DIR_HOST)/bin/libtool
endef
define Host/Uninstall
-$(call Host/Compile/Default,uninstall)
-endef
-
-define Host/Clean
- $(call Host/Clean/Default)
+ (cd $(STAGING_DIR_HOST)/share/aclocal/ && rm -f libtool.m4 ltdl.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4)
endef
$(eval $(call HostBuild))