summaryrefslogtreecommitdiffstats
path: root/tools/libtool
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-03-23 03:53:52 -0400
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-04 06:07:30 +0200
commit87e902fcdcce0e3d1287deb901f934aabf7ec183 (patch)
tree72e8fb21e2c40250fa9c6a78e3e6a20cec59a849 /tools/libtool
parentd95d5d2a3a895f5374b56ab349f628578cd4149b (diff)
downloadopenwrt-87e902fcdcce0e3d1287deb901f934aabf7ec183.tar.gz
openwrt-87e902fcdcce0e3d1287deb901f934aabf7ec183.tar.bz2
openwrt-87e902fcdcce0e3d1287deb901f934aabf7ec183.zip
tools/libtool: bootstrap to local gnulib source
Using the local gnulib source during bootstrap allows for fine-grained control over the macros and source files for use with libtool but part of gnulib instead of libtool, without having to wait for a release or deal with gnulib as a git submodule. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'tools/libtool')
-rw-r--r--tools/libtool/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/tools/libtool/Makefile b/tools/libtool/Makefile
index b4f3ecc36b..1187191478 100644
--- a/tools/libtool/Makefile
+++ b/tools/libtool/Makefile
@@ -18,17 +18,31 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+export GNULIB_SRCDIR:=$(HOST_GNULIB_SRCDIR)
+
HOST_CONFIGURE_VARS += \
lt_cv_sys_dlsearch_path=""
+define Host/Bootstrap
+ ( \
+ cd $(HOST_BUILD_DIR); \
+ $(AM_TOOL_PATHS) \
+ ./bootstrap \
+ --force \
+ --skip-git \
+ --skip-po \
+ --gnulib-srcdir=$(GNULIB_SRCDIR) \
+ )
+endef
+
define Host/Prepare
$(call Host/Prepare/Default)
$(call Host/Uninstall)
- $(if $(QUILT),,(cd $(HOST_BUILD_DIR); touch README-release; $(AM_TOOL_PATHS) ./bootstrap --skip-git --skip-po --force))
+ $(if $(QUILT),,$(call Host/Bootstrap))
endef
define Host/Configure
- $(if $(QUILT),(cd $(HOST_BUILD_DIR); touch README-release; $(AM_TOOL_PATHS) ./bootstrap --skip-git --skip-po --force))
+ $(if $(QUILT),$(call Host/Bootstrap))
$(call Host/Configure/Default)
endef