summaryrefslogtreecommitdiffstats
path: root/tools/lzma-old
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-04-15 19:24:02 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-04-28 15:28:59 +0200
commit8dcd941d8b934891676a8d4bbef1ee78e89a4bf7 (patch)
tree8889465aa25467269f09f9b39ef9e5fe5a519fa0 /tools/lzma-old
parentafdca53acee25f452bd2c405cb3943db34492585 (diff)
downloadopenwrt-8dcd941d8b934891676a8d4bbef1ee78e89a4bf7.tar.gz
openwrt-8dcd941d8b934891676a8d4bbef1ee78e89a4bf7.tar.bz2
openwrt-8dcd941d8b934891676a8d4bbef1ee78e89a4bf7.zip
tools/zlib: move zlib build to tools
This allows us to link the other tools against our libz and we do not need the system zlib any more. Only the static linked library is copied to the staging directory so we have a statically linked library on all systems and not only on Linux. This also adds the new dependencies of the packages which are depending on zlib. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> Tested-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'tools/lzma-old')
-rw-r--r--tools/lzma-old/Makefile2
-rw-r--r--tools/lzma-old/patches/120-add-cflags.patch11
2 files changed, 13 insertions, 0 deletions
diff --git a/tools/lzma-old/Makefile b/tools/lzma-old/Makefile
index 5982eab5db..5204127a80 100644
--- a/tools/lzma-old/Makefile
+++ b/tools/lzma-old/Makefile
@@ -21,7 +21,9 @@ LIB_DIR=$(HOST_BUILD_DIR)/C/7zip/Compress/LZMA_Lib
ALONE_DIR=$(HOST_BUILD_DIR)/C/7zip/Compress/LZMA_Alone
define Host/Compile
+ +$(HOST_MAKE_VARS) \
$(MAKE) -C $(LIB_DIR)
+ +$(HOST_MAKE_VARS) \
$(MAKE) -f makefile.gcc -C $(ALONE_DIR)
endef
diff --git a/tools/lzma-old/patches/120-add-cflags.patch b/tools/lzma-old/patches/120-add-cflags.patch
new file mode 100644
index 0000000000..9022e7cd27
--- /dev/null
+++ b/tools/lzma-old/patches/120-add-cflags.patch
@@ -0,0 +1,11 @@
+--- a/C/7zip/Compress/LZMA_Lib/makefile
++++ b/C/7zip/Compress/LZMA_Lib/makefile
+@@ -2,7 +2,7 @@ PROG = liblzma.a
+ CXX = g++ -O3 -Wall
+ AR = ar
+ RM = rm -f
+-CFLAGS = -c -I ../../../
++CFLAGS += -c -I ../../../
+
+ OBJS = \
+ ZLib.o \