summaryrefslogtreecommitdiffstats
path: root/tools/make-ext4fs
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-04-28 18:20:20 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-04-29 00:57:07 +0200
commit60427a940f084efea7fbfc3f072dc4cff80b7e33 (patch)
treef0c47829f3fbac6b2b53d9a5e77459a6a2d21107 /tools/make-ext4fs
parent2c192b69163fe8809a79b422abea06b41f9be1fb (diff)
downloadopenwrt-60427a940f084efea7fbfc3f072dc4cff80b7e33.tar.gz
openwrt-60427a940f084efea7fbfc3f072dc4cff80b7e33.tar.bz2
openwrt-60427a940f084efea7fbfc3f072dc4cff80b7e33.zip
tools/make-ext4fs: Fix build on MacOSX
MacOSX does not support "-Wl,-Bstatic" so do not force the static linking. We only copy the static libz library into the staging libraries directories, the linker will anyway only find the static version and link against that on all systems. Fixes: 8dcd941d8b9 ("tools/zlib: move zlib build to tools") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'tools/make-ext4fs')
-rw-r--r--tools/make-ext4fs/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/tools/make-ext4fs/Makefile b/tools/make-ext4fs/Makefile
index 97f9e6369c..f67ab6e5b5 100644
--- a/tools/make-ext4fs/Makefile
+++ b/tools/make-ext4fs/Makefile
@@ -17,8 +17,6 @@ PKG_MIRROR_HASH:=d7ccd5e426b1d15331ff000a37dc15161f6eef594453e970fd584fcde5a2507
include $(INCLUDE_DIR)/host-build.mk
-HOST_MAKE_FLAGS += STATIC=1
-
define Host/Install
$(INSTALL_BIN) $(HOST_BUILD_DIR)/make_ext4fs $(STAGING_DIR_HOST)/bin/
endef