summaryrefslogtreecommitdiffstats
path: root/tools/meson
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-03-16 16:18:07 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2022-04-09 15:56:04 +0200
commit19f3fcc884cab348cfba823f1175baf7aa4de15f (patch)
treeb540c8cddc4bd0a32567e06b7305d841b5264106 /tools/meson
parent56f091d4677feb693d37959a3fa4af845dcce82e (diff)
downloadopenwrt-19f3fcc884cab348cfba823f1175baf7aa4de15f.tar.gz
openwrt-19f3fcc884cab348cfba823f1175baf7aa4de15f.tar.bz2
openwrt-19f3fcc884cab348cfba823f1175baf7aa4de15f.zip
tools/meson: update to 0.61.4
Override python to use the one in host instead of hostpkg. There's no need to use the latter. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/meson')
-rw-r--r--tools/meson/Makefile4
-rw-r--r--tools/meson/files/openwrt-cross.txt.in1
-rw-r--r--tools/meson/files/openwrt-native.txt.in1
3 files changed, 4 insertions, 2 deletions
diff --git a/tools/meson/Makefile b/tools/meson/Makefile
index cd5af31cff..e2ea3d285c 100644
--- a/tools/meson/Makefile
+++ b/tools/meson/Makefile
@@ -1,11 +1,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=meson
-PKG_VERSION:=0.61.2
+PKG_VERSION:=0.61.4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/mesonbuild/meson/releases/download/$(PKG_VERSION)
-PKG_HASH:=0233a7f8d959079318f6052b0939c27f68a5de86ba601f25c9ee6869fb5f5889
+PKG_HASH:=4e3733ddc66bac38e38c63b739c9b8b8fc5a866de5333396b0c85c2b144ddee9
PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
PKG_LICENSE:=Apache-2.0
diff --git a/tools/meson/files/openwrt-cross.txt.in b/tools/meson/files/openwrt-cross.txt.in
index 56aa393d63..ec4b027f1b 100644
--- a/tools/meson/files/openwrt-cross.txt.in
+++ b/tools/meson/files/openwrt-cross.txt.in
@@ -6,6 +6,7 @@ strip = '@STRIP@'
nm = '@NM@'
pkgconfig = '@PKGCONFIG@'
cmake = '@CMAKE@'
+python = '@PYTHON@'
[built-in options]
c_args = [@CFLAGS@]
diff --git a/tools/meson/files/openwrt-native.txt.in b/tools/meson/files/openwrt-native.txt.in
index eba63c00b1..48e09ece2c 100644
--- a/tools/meson/files/openwrt-native.txt.in
+++ b/tools/meson/files/openwrt-native.txt.in
@@ -3,6 +3,7 @@ c = [@CC@]
cpp = [@CXX@]
pkgconfig = '@PKGCONFIG@'
cmake = '@CMAKE@'
+python = '@PYTHON@'
[built-in options]
c_args = [@CFLAGS@]