summaryrefslogtreecommitdiffstats
path: root/tools/meson
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-11-22 00:51:08 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2021-12-05 18:49:14 +0100
commit75093d1b1de7af82acd3b8bcc61f308c37493400 (patch)
tree2d34b0f608a409ebc32e1c9ccdacc17610fac3ba /tools/meson
parent362695acdfa78ad6206ac385962ded589dad5b7c (diff)
downloadopenwrt-75093d1b1de7af82acd3b8bcc61f308c37493400.tar.gz
openwrt-75093d1b1de7af82acd3b8bcc61f308c37493400.tar.bz2
openwrt-75093d1b1de7af82acd3b8bcc61f308c37493400.zip
tools/meson: update to 0.60.1
change meson binary to use py extension. Fixes issue with meson's symbolextractor using the host python instead of the system one. We intentionally use a .py extension here so that meson launches additional python scripts with the same build host python interpreter as itself is running under (and not the host package one once it becomes available) Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/meson')
-rw-r--r--tools/meson/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/meson/Makefile b/tools/meson/Makefile
index f648085f90..10f29c93d8 100644
--- a/tools/meson/Makefile
+++ b/tools/meson/Makefile
@@ -1,11 +1,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=meson
-PKG_VERSION:=0.60.0
+PKG_VERSION:=0.60.1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/mesonbuild/meson/releases/download/$(PKG_VERSION)
-PKG_HASH:=080d68b685e9a0d9c9bb475457e097b49e1d1a6f750abc971428a8d2e1b12d47
+PKG_HASH:=5add789c953d984b500858b2851ee3d7add0460cf1a6f852f0a721af17384e13
PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
PKG_LICENSE:=Apache-2.0
@@ -21,7 +21,7 @@ endef
define Host/Install
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
- $(HOST_BUILD_DIR)/packaging/create_zipapp.py $(HOST_BUILD_DIR) --outfile $(STAGING_DIR_HOST)/bin/meson
+ $(HOST_BUILD_DIR)/packaging/create_zipapp.py $(HOST_BUILD_DIR) --outfile $(STAGING_DIR_HOST)/bin/meson.py
$(INSTALL_DIR) $(STAGING_DIR_HOST)/lib/meson
$(INSTALL_CONF) files/openwrt-cross.txt.in $(STAGING_DIR_HOST)/lib/meson/
$(INSTALL_CONF) files/openwrt-native.txt.in $(STAGING_DIR_HOST)/lib/meson/