summaryrefslogtreecommitdiffstats
path: root/tools/meson
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2024-02-21 13:13:34 -0800
committerPaul Spooren <mail@aparcar.org>2024-03-29 23:42:22 +0100
commitfcdc629144983cf5e3f5509e35149096aa2701b3 (patch)
tree5f64a97cd44647e3edc4921d7ee99de675ebf562 /tools/meson
parent4ae474afbd023a3386f4276ca8f948a44b49ff1b (diff)
downloadopenwrt-fcdc629144983cf5e3f5509e35149096aa2701b3.tar.gz
openwrt-fcdc629144983cf5e3f5509e35149096aa2701b3.tar.bz2
openwrt-fcdc629144983cf5e3f5509e35149096aa2701b3.zip
tools/meson: update to 1.3.2
Add explicit setup as implicit is deprecated. Rename pkgconfig as no hyphen is deprecated. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/meson')
-rw-r--r--tools/meson/Makefile4
-rw-r--r--tools/meson/files/openwrt-cross.txt.in2
-rw-r--r--tools/meson/files/openwrt-native.txt.in2
3 files changed, 4 insertions, 4 deletions
diff --git a/tools/meson/Makefile b/tools/meson/Makefile
index 23bb393a59..96974faafe 100644
--- a/tools/meson/Makefile
+++ b/tools/meson/Makefile
@@ -1,11 +1,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=meson
-PKG_VERSION:=1.2.1
+PKG_VERSION:=1.3.2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/mesonbuild/meson/releases/download/$(PKG_VERSION)
-PKG_HASH:=b1db3a153087549497ee52b1c938d2134e0338214fe14f7efd16fecd57b639f5
+PKG_HASH:=492eb450c8b073024276f916f5adbb3c4bb7e90e9e6ec124efda064f3d9b5baa
PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
PKG_LICENSE:=Apache-2.0
diff --git a/tools/meson/files/openwrt-cross.txt.in b/tools/meson/files/openwrt-cross.txt.in
index ba11915069..836a0e51e4 100644
--- a/tools/meson/files/openwrt-cross.txt.in
+++ b/tools/meson/files/openwrt-cross.txt.in
@@ -6,7 +6,7 @@ cpp_ld = [@LD@]
ar = '@AR@'
strip = '@STRIP@'
nm = '@NM@'
-pkgconfig = '@PKGCONFIG@'
+pkg-config = '@PKGCONFIG@'
cmake = '@CMAKE@'
python = '@PYTHON@'
diff --git a/tools/meson/files/openwrt-native.txt.in b/tools/meson/files/openwrt-native.txt.in
index 48e09ece2c..179e00b43e 100644
--- a/tools/meson/files/openwrt-native.txt.in
+++ b/tools/meson/files/openwrt-native.txt.in
@@ -1,7 +1,7 @@
[binaries]
c = [@CC@]
cpp = [@CXX@]
-pkgconfig = '@PKGCONFIG@'
+pkg-config = '@PKGCONFIG@'
cmake = '@CMAKE@'
python = '@PYTHON@'