summaryrefslogtreecommitdiffstats
path: root/tools/mkimage
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2024-04-06 14:49:54 +0200
committerNick Hainke <vincent@systemli.org>2024-04-06 14:52:06 +0200
commit0a0d89265ee474d0784f675d65685ed011cc30b3 (patch)
tree0b2c8f48040d2947f3297f47211fd9b7df0d03b9 /tools/mkimage
parent076e86041862ff7962c395706238c69fc8b83594 (diff)
downloadopenwrt-0a0d89265ee474d0784f675d65685ed011cc30b3.tar.gz
openwrt-0a0d89265ee474d0784f675d65685ed011cc30b3.tar.bz2
openwrt-0a0d89265ee474d0784f675d65685ed011cc30b3.zip
Revert "tools/mkimage: update to v2024.04"
This reverts commit 8d934c11968de49ad17bc62366a88230e47b4f56. The update seems to be causing issues that need to be further explored [0]. Let's revert it. [0] - https://github.com/openwrt/openwrt/pull/15078 Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'tools/mkimage')
-rw-r--r--tools/mkimage/Makefile4
-rw-r--r--tools/mkimage/patches/030-allow-to-use-different-magic.patch4
-rw-r--r--tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch2
3 files changed, 5 insertions, 5 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index 6d2cc5f764..ae744f9bf3 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -7,14 +7,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
-PKG_VERSION:=2024.04
+PKG_VERSION:=2024.01
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
https://mirror.cyberbits.eu/u-boot \
https://ftp.denx.de/pub/u-boot \
ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=18a853fe39fad7ad03a90cc2d4275aeaed6da69735defac3492b80508843dd4a
+PKG_HASH:=b99611f1ed237bf3541bdc8434b68c96a6e05967061f992443cb30aabebef5b3
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
diff --git a/tools/mkimage/patches/030-allow-to-use-different-magic.patch b/tools/mkimage/patches/030-allow-to-use-different-magic.patch
index bcbdc4d6cd..f2f57965f6 100644
--- a/tools/mkimage/patches/030-allow-to-use-different-magic.patch
+++ b/tools/mkimage/patches/030-allow-to-use-different-magic.patch
@@ -24,7 +24,7 @@ This patch makes it possible to set a custom image magic.
" -a ==> set load address to 'addr' (hex)\n"
" -e ==> set entry point to 'ep' (hex)\n"
" -n ==> set image name to 'name'\n"
-@@ -160,7 +162,7 @@ static int add_content(int type, const c
+@@ -159,7 +161,7 @@ static int add_content(int type, const c
}
static const char optstring[] =
@@ -33,7 +33,7 @@ This patch makes it possible to set a custom image magic.
static const struct option longopts[] = {
{ "load-address", required_argument, NULL, 'a' },
-@@ -303,6 +305,14 @@ static void process_args(int argc, char
+@@ -302,6 +304,14 @@ static void process_args(int argc, char
case 'l':
params.lflag = 1;
break;
diff --git a/tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch b/tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch
index ed6824b11a..f2e3b9b053 100644
--- a/tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch
+++ b/tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch
@@ -14,7 +14,7 @@ https://github.com/u-boot/u-boot/commit/3f04db891a353f4b127ed57279279f851c6b4917
--- a/tools/Kconfig
+++ b/tools/Kconfig
-@@ -36,7 +36,7 @@ config TOOLS_FIT
+@@ -31,7 +31,7 @@ config TOOLS_FIT
Enable FIT support in the tools builds.
config TOOLS_FIT_FULL_CHECK