summaryrefslogtreecommitdiffstats
path: root/tools/mkimage
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-19 14:59:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-19 14:59:26 +0000
commit0fc6755f66c842c2b25768bf954fdf60355c21e0 (patch)
tree6b7afc7fc10749c4f5f21bbbf26b1c47dd7e2868 /tools/mkimage
parent13f50151bc99f2d36d768e6b9da7d11aa0a00507 (diff)
downloadopenwrt-0fc6755f66c842c2b25768bf954fdf60355c21e0.tar.gz
openwrt-0fc6755f66c842c2b25768bf954fdf60355c21e0.tar.bz2
openwrt-0fc6755f66c842c2b25768bf954fdf60355c21e0.zip
mkimage: cross compile fix: pass HOST_*FLAGS in to uboot's makefile
The HOST_*FLAGS are for compiling programs which will run on the machine that is running the build. Setting these flags is frequently required for unusual cross-compiles. Signed-off-by: Lawrence D'Anna <larry@elder-gods.org> SVN-Revision: 46424
Diffstat (limited to 'tools/mkimage')
-rw-r--r--tools/mkimage/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index a65eedfcc6..f73cc56318 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -31,8 +31,8 @@ define Host/Prepare
endef
define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR) defconfig
- $(MAKE) -C $(HOST_BUILD_DIR) tools-only
+ $(MAKE) -C $(HOST_BUILD_DIR) defconfig HOSTCFLAGS="$(HOST_CPPFLAGS) $(HOST_CFLAGS)" HOSTLDFLAGS="$(HOST_LDFLAGS)"
+ $(MAKE) -C $(HOST_BUILD_DIR) tools-only HOSTCFLAGS="$(HOST_CPPFLAGS) $(HOST_CFLAGS)" HOSTLDFLAGS="$(HOST_LDFLAGS)"
endef
define Host/Install