summaryrefslogtreecommitdiffstats
path: root/tools/mkimage
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-11-29 22:43:59 +0000
committerLuka Perkov <luka@openwrt.org>2014-11-29 22:43:59 +0000
commit25d8cb275e1f16bb80c6d05dcf6d73d8d6882053 (patch)
tree7f6d41071498538edf4f3927515e4d84e65f66eb /tools/mkimage
parent070d3b27c223f23a4793667264441f8c2f008755 (diff)
downloadopenwrt-25d8cb275e1f16bb80c6d05dcf6d73d8d6882053.tar.gz
openwrt-25d8cb275e1f16bb80c6d05dcf6d73d8d6882053.tar.bz2
openwrt-25d8cb275e1f16bb80c6d05dcf6d73d8d6882053.zip
mkimage: update to 2014.10
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 43428
Diffstat (limited to 'tools/mkimage')
-rw-r--r--tools/mkimage/Makefile9
-rw-r--r--tools/mkimage/patches/020-include_compile_fix.patch10
-rw-r--r--tools/mkimage/patches/020-openbsd_fixes.patch18
-rw-r--r--tools/mkimage/patches/040-include_order.patch4
-rw-r--r--tools/mkimage/patches/050-image_h_portability.patch2
-rw-r--r--tools/mkimage/patches/060-remove_kernel_includes.patch4
6 files changed, 21 insertions, 26 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index 49eb26184d..2de13ab77b 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -7,11 +7,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
-PKG_VERSION:=2014.07
+PKG_VERSION:=2014.10
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=36d4bad687edcafa396fee607e505d4e
+PKG_SOURCE_URL:=\
+ http://mirror2.openwrt.org/sources \
+ ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=3ddcaee2f05b7c464778112ec83664b5
PKG_CAT:=bzcat
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
@@ -29,6 +31,7 @@ define Host/Prepare
endef
define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) defconfig
$(MAKE) -C $(HOST_BUILD_DIR) \
HOSTLDFLAGS="$(HOST_STATIC_LINKING)" \
tools-only
diff --git a/tools/mkimage/patches/020-include_compile_fix.patch b/tools/mkimage/patches/020-include_compile_fix.patch
new file mode 100644
index 0000000000..276cae0cb1
--- /dev/null
+++ b/tools/mkimage/patches/020-include_compile_fix.patch
@@ -0,0 +1,10 @@
+--- a/include/u-boot/rsa-checksum.h
++++ b/include/u-boot/rsa-checksum.h
+@@ -7,7 +7,6 @@
+ #ifndef _RSA_CHECKSUM_H
+ #define _RSA_CHECKSUM_H
+
+-#include <errno.h>
+ #include <image.h>
+ #include <u-boot/sha1.h>
+ #include <u-boot/sha256.h>
diff --git a/tools/mkimage/patches/020-openbsd_fixes.patch b/tools/mkimage/patches/020-openbsd_fixes.patch
deleted file mode 100644
index 7a762d91f7..0000000000
--- a/tools/mkimage/patches/020-openbsd_fixes.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/tools/mkimage.c
-+++ b/tools/mkimage.c
-@@ -458,6 +458,7 @@
- #if defined(_POSIX_SYNCHRONIZED_IO) && \
- !defined(__sun__) && \
- !defined(__FreeBSD__) && \
-+ !defined(__OpenBSD__) && \
- !defined(__APPLE__)
- (void) fdatasync (ifd);
- #else
-@@ -501,6 +502,7 @@
- #if defined(_POSIX_SYNCHRONIZED_IO) && \
- !defined(__sun__) && \
- !defined(__FreeBSD__) && \
-+ !defined(__OpenBSD__) && \
- !defined(__APPLE__)
- (void) fdatasync (ifd);
- #else
diff --git a/tools/mkimage/patches/040-include_order.patch b/tools/mkimage/patches/040-include_order.patch
index 66f703c855..3b9ecc6bd3 100644
--- a/tools/mkimage/patches/040-include_order.patch
+++ b/tools/mkimage/patches/040-include_order.patch
@@ -1,10 +1,10 @@
--- a/tools/Makefile
+++ b/tools/Makefile
-@@ -193,7 +193,7 @@
+@@ -194,7 +194,7 @@ endif # !LOGO_BMP
# Define _GNU_SOURCE to obtain the getline prototype from stdio.h
#
HOST_EXTRACFLAGS += -include $(srctree)/include/libfdt_env.h \
-- $(patsubst -I%,-idirafter%, $(UBOOTINCLUDE)) \
+- $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \
+ -I$(srctree)/include \
-I$(srctree)/lib/libfdt \
-I$(srctree)/tools \
diff --git a/tools/mkimage/patches/050-image_h_portability.patch b/tools/mkimage/patches/050-image_h_portability.patch
index 304a7aa247..b3ad27388c 100644
--- a/tools/mkimage/patches/050-image_h_portability.patch
+++ b/tools/mkimage/patches/050-image_h_portability.patch
@@ -8,7 +8,7 @@
/* Define this to avoid #ifdefs later on */
struct lmb;
-@@ -257,13 +256,13 @@
+@@ -258,13 +257,13 @@ struct lmb;
* all data in network byte order (aka natural aka bigendian).
*/
typedef struct image_header {
diff --git a/tools/mkimage/patches/060-remove_kernel_includes.patch b/tools/mkimage/patches/060-remove_kernel_includes.patch
index 9462ca6aa8..fa533cd22d 100644
--- a/tools/mkimage/patches/060-remove_kernel_includes.patch
+++ b/tools/mkimage/patches/060-remove_kernel_includes.patch
@@ -1,6 +1,6 @@
--- a/include/compiler.h
+++ b/include/compiler.h
-@@ -53,6 +53,11 @@
+@@ -58,6 +58,11 @@ typedef uint8_t __u8;
typedef uint16_t __u16;
typedef uint32_t __u32;
typedef unsigned int uint;
@@ -14,7 +14,7 @@
((((x) & 0xff00) >> 8) | \
--- a/include/linux/posix_types.h
+++ b/include/linux/posix_types.h
-@@ -43,6 +43,8 @@
+@@ -43,6 +43,8 @@ typedef void (*__kernel_sighandler_t)(in
/* Type of a SYSV IPC key. */
typedef int __kernel_key_t;