summaryrefslogtreecommitdiffstats
path: root/tools/mkimage
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2024-04-05 12:18:41 +0200
committerNick Hainke <vincent@systemli.org>2024-04-06 08:02:40 +0200
commit8d934c11968de49ad17bc62366a88230e47b4f56 (patch)
tree82bb157c208c99601efbdfa69ac3b7883f1672b8 /tools/mkimage
parente6f7e9dca916626a6d5dd22835d3c91be052f708 (diff)
downloadopenwrt-8d934c11968de49ad17bc62366a88230e47b4f56.tar.gz
openwrt-8d934c11968de49ad17bc62366a88230e47b4f56.tar.bz2
openwrt-8d934c11968de49ad17bc62366a88230e47b4f56.zip
tools/mkimage: update to v2024.04
Update to latest version. Refresh patches: - 030-allow-to-use-different-magic.patch - 095-tools-disable-TOOLS_FIT_FULL_CHECK.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'tools/mkimage')
-rw-r--r--tools/mkimage/Makefile4
-rw-r--r--tools/mkimage/patches/030-allow-to-use-different-magic.patch4
-rw-r--r--tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch2
3 files changed, 5 insertions, 5 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index ae744f9bf3..6d2cc5f764 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -7,14 +7,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
-PKG_VERSION:=2024.01
+PKG_VERSION:=2024.04
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
https://mirror.cyberbits.eu/u-boot \
https://ftp.denx.de/pub/u-boot \
ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=b99611f1ed237bf3541bdc8434b68c96a6e05967061f992443cb30aabebef5b3
+PKG_HASH:=18a853fe39fad7ad03a90cc2d4275aeaed6da69735defac3492b80508843dd4a
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
diff --git a/tools/mkimage/patches/030-allow-to-use-different-magic.patch b/tools/mkimage/patches/030-allow-to-use-different-magic.patch
index f2f57965f6..bcbdc4d6cd 100644
--- a/tools/mkimage/patches/030-allow-to-use-different-magic.patch
+++ b/tools/mkimage/patches/030-allow-to-use-different-magic.patch
@@ -24,7 +24,7 @@ This patch makes it possible to set a custom image magic.
" -a ==> set load address to 'addr' (hex)\n"
" -e ==> set entry point to 'ep' (hex)\n"
" -n ==> set image name to 'name'\n"
-@@ -159,7 +161,7 @@ static int add_content(int type, const c
+@@ -160,7 +162,7 @@ static int add_content(int type, const c
}
static const char optstring[] =
@@ -33,7 +33,7 @@ This patch makes it possible to set a custom image magic.
static const struct option longopts[] = {
{ "load-address", required_argument, NULL, 'a' },
-@@ -302,6 +304,14 @@ static void process_args(int argc, char
+@@ -303,6 +305,14 @@ static void process_args(int argc, char
case 'l':
params.lflag = 1;
break;
diff --git a/tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch b/tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch
index f2e3b9b053..ed6824b11a 100644
--- a/tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch
+++ b/tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch
@@ -14,7 +14,7 @@ https://github.com/u-boot/u-boot/commit/3f04db891a353f4b127ed57279279f851c6b4917
--- a/tools/Kconfig
+++ b/tools/Kconfig
-@@ -31,7 +31,7 @@ config TOOLS_FIT
+@@ -36,7 +36,7 @@ config TOOLS_FIT
Enable FIT support in the tools builds.
config TOOLS_FIT_FULL_CHECK