summaryrefslogtreecommitdiffstats
path: root/tools/mkimage
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-04-19 08:26:15 +0200
committerJo-Philipp Wich <jo@mein.io>2018-04-19 08:34:34 +0200
commita656ea0bdb5d3d4a4948457942e84faa5a4f5cfe (patch)
treefd0e8374b2b013a8c2f2ca0b7a9d51cc1bd54232 /tools/mkimage
parent3c79bb560665b88b4066ba9e818ace71dfdb6f1f (diff)
downloadopenwrt-a656ea0bdb5d3d4a4948457942e84faa5a4f5cfe.tar.gz
openwrt-a656ea0bdb5d3d4a4948457942e84faa5a4f5cfe.tar.bz2
openwrt-a656ea0bdb5d3d4a4948457942e84faa5a4f5cfe.zip
tools: mkimage: provide dtc path during build
The new mkimage version requires a CONFIG_MKIMAGE_DTC_PATH variable to be provided during build, in order to hardcode a path to a suitable DT compiler executable. Failure to do so will result in stray "sh: 1: -I: not found" errors when invoking mkimage for FIT image generation. Fix the issue by supplying "dtc" as CONFIG_MKIMAGE_DTC_PATH value during build. As we intend our host utilities to be relocatable and since we're already overriding PATH when invoking mkimage, an absolute path is not required. Fixes: b13e981d72 ("tools/mkimage: update to version 2018.03") Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'tools/mkimage')
-rw-r--r--tools/mkimage/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index c7e1dfd672..d0ff5f7e37 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -30,6 +30,7 @@ define Host/Compile
HOSTCFLAGS="$(HOST_CFLAGS)" \
HOSTLDFLAGS="$(HOST_LDFLAGS)" \
no-dot-config-targets=tools-only \
+ CONFIG_MKIMAGE_DTC_PATH=dtc \
CONFIG_FIT_SIGNATURE=y \
tools-only
endef