summaryrefslogtreecommitdiffstats
path: root/tools/patch
diff options
context:
space:
mode:
authorRussell Senior <russell@personaltelco.net>2018-02-11 23:40:59 -0800
committerYousong Zhou <yszhou4tech@gmail.com>2018-02-12 16:27:56 +0800
commit89a0fed2a2d2fc8b5e8eef4247f572ed9b53e72b (patch)
tree5953abc3f3c45ddb04e771c3d6a6870cda1fac4a /tools/patch
parente2ec3f7550ccf66a000262b7c33a2a87524c5257 (diff)
downloadopenwrt-89a0fed2a2d2fc8b5e8eef4247f572ed9b53e72b.tar.gz
openwrt-89a0fed2a2d2fc8b5e8eef4247f572ed9b53e72b.tar.bz2
openwrt-89a0fed2a2d2fc8b5e8eef4247f572ed9b53e72b.zip
tools: update patch to v2.7.6
Removes a redundant patch with a fix already upstream. Build tested on apm821xx (PPC). Signed-off-by: Russell Senior <russell@personaltelco.net>
Diffstat (limited to 'tools/patch')
-rw-r--r--tools/patch/Makefile4
-rw-r--r--tools/patch/patches/001-fix-macos-vasnprintf.patch25
2 files changed, 2 insertions, 27 deletions
diff --git a/tools/patch/Makefile b/tools/patch/Makefile
index 9866e2055d..4c4c09bc08 100644
--- a/tools/patch/Makefile
+++ b/tools/patch/Makefile
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=patch
-PKG_VERSION:=2.7.5
+PKG_VERSION:=2.7.6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/patch
-PKG_HASH:=fd95153655d6b95567e623843a0e77b81612d502ecf78a489a4aed7867caa299
+PKG_HASH:=ac610bda97abe0d9f6b7c963255a11dcb196c25e337c61f94e4778d632f1d8fd
HOST_BUILD_PARALLEL := 1
diff --git a/tools/patch/patches/001-fix-macos-vasnprintf.patch b/tools/patch/patches/001-fix-macos-vasnprintf.patch
deleted file mode 100644
index e41315d34e..0000000000
--- a/tools/patch/patches/001-fix-macos-vasnprintf.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/lib/vasnprintf.c
-+++ b/lib/vasnprintf.c
-@@ -4858,7 +4858,11 @@ VASNPRINTF (DCHAR_T *resultbuf, size_t *
- #endif
- *fbp = dp->conversion;
- #if USE_SNPRINTF
--# if !(((__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 3)) && !defined __UCLIBC__) || ((defined _WIN32 || defined __WIN32__) && ! defined __CYGWIN__))
-+# if ! (((__GLIBC__ > 2 \
-+ || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 3)) \
-+ && !defined __UCLIBC__) \
-+ || (defined __APPLE__ && defined __MACH__) \
-+ || ((defined _WIN32 || defined __WIN32__) && ! defined __CYGWIN__))
- fbp[1] = '%';
- fbp[2] = 'n';
- fbp[3] = '\0';
-@@ -4872,6 +4876,9 @@ VASNPRINTF (DCHAR_T *resultbuf, size_t *
- in format strings in writable memory may crash the program
- (if compiled with _FORTIFY_SOURCE=2), so we should avoid it
- in this situation. */
-+ /* macOS 10.13 High Sierra behaves like glibc with
-+ _FORTIFY_SOURCE=2, and older macOS releases
-+ presumably do not need %n. */
- /* On native Windows systems (such as mingw), we can avoid using
- %n because:
- - Although the gl_SNPRINTF_TRUNCATION_C99 test fails,