summaryrefslogtreecommitdiffstats
path: root/tools/quilt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-25 19:02:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-25 19:02:48 +0000
commit58765184c64105ef29a72f221df8c9f2e6207fb6 (patch)
treebeca0248efb033b7e537880f702cc7fcea7e4dcb /tools/quilt
parentca8486a632823e6ed40c0d748cd08387a52615d5 (diff)
downloadopenwrt-58765184c64105ef29a72f221df8c9f2e6207fb6.tar.gz
openwrt-58765184c64105ef29a72f221df8c9f2e6207fb6.tar.bz2
openwrt-58765184c64105ef29a72f221df8c9f2e6207fb6.zip
detect quilt configure errors properly (their broken configure script does not return proper error codes)
SVN-Revision: 14181
Diffstat (limited to 'tools/quilt')
-rw-r--r--tools/quilt/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/quilt/Makefile b/tools/quilt/Makefile
index 49da92b734..5294534b01 100644
--- a/tools/quilt/Makefile
+++ b/tools/quilt/Makefile
@@ -15,6 +15,11 @@ PKG_MD5SUM:=d33d2442bd34387260b1c1db3e623af0
include $(INCLUDE_DIR)/host-build.mk
+define Build/Configure
+ $(call Build/Configure/Default)
+ [ -f $(PKG_BUILD_DIR)/Makefile ]
+endef
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) SHELL="$(BASH)"
endef